Click to play (--enable-click-to-play) not working

There’s a flag in the chromium based browsers to enable a build-in plugin blocker in the preferences dragon://settings/content
To enable this option, you can add --enable-click-to-play to the command-line options, or enable it in the about:flags options.
It’s been around for a while

If you encounter a flash element on a page in Chome/Chromium/Iron and the “Click to play” option is selected, than you’d just have to click the grey placeholder and the flash element /plugin is loaded.

In Dragon: the placeholder is white, which is hard to distinguish from the usual website background.
Also, you have to right click and than enable the plugin. (which is the same behavior as selecting the Block all option in the preferences)

I’ve tried with the standard flash plugin downloaded from and by copying the gcswf32.dll + flashplayercplapp.cpl from the chrome install folder, but it still doesn’t work as the other chromium based browsers.

Additional Info

  • Version: 12.2 stable
  • Plugins/Themes: default theme, Flash 10.3
  • Windows 7 PS1 64-bit
  • UAC: Enabled, highest level
  • System Drive: C-drive
  • Install path: C:\Program Files (x86)\Internet Tools\Comodo Dragon
  • User priveleges: tested as admin and limited user

[attachment deleted by admin]