Cleaning Essentials. Getting Error 5 [M2424]

Hi everybody.
I’m new of Comodo, (and I take this opportunity to congratulate the boys).

I have an issue for installation: Cleaning Essentials. Getting Error 5.

And now ?

Yes a known issue with CIS must wait for a new release for a fix.

Thanks futuretech.
I’ll wait :-TU

Sorry intrusion, the problem seems to be the permissions …
Desktop virtual installer normal, but killswitch ou clean essentials not.
comodo internet security download database malware complete…

Thank you for reporting, this is known issue, developers are working on it.

Fixed in beta 1

waiting for new release because i have same issue about it.

I have same problem.

Hi colchis & cyber34tr,

Thank you for reporting.
This is an Known issue in v12.1.0.6914,now it’s Fixed in the v12.2.0.6938 Beta 1 and it will be reflected in the upcoming stable release.


Looks like I get access denied when trying to install and run Killswitch. Image attached.

Please use search it is a known issue that you need to wait for next release for fix.


I have been trying to install the “KillSwitch” for more than 2 weeks now, but getting the same error message. Tried a fresh install of Windows 10 (1909) and running “COMODO Firewall” as ‘Administrator’ but no luck. FYI, i installed the COMODO Firewall using the installer package ( cmd_fw_installer_138430009_eb ). Anyone else facing this issue ?

Got it, thank you!

Hi, i have installed CIS Pro version Database Version 32027 Website Database 53426. I tried to install Killswitch it download but when installing i get the error access denied error 5 access refused. I have CIS Pro so how to fix this issue.

It’s a known and verified issue with 6914. The next stable version is due out very soon where this is fixed - unless you wish to install Beta2 6950 in the meantime, where it is also fixed

Merged Topic - awaiting new release

With latest version it’s not possible to install KillSwitch nor Clean Enpoint modules since it gives “Error 5: Access is denied” due to Comodo not being able to write the files for these modules in the “C:\Program Files\Comodo\Comodo Internet Security” and C:\ProgramData\Comodo" folders due to protection set by Comodo running services. I replicated problem in a clean Windows 10 VM (1909). Only way to manually install these modules is by booting Windows into safe mode (exiting Comodo GUI or disabling protection modules does not affect the folder protection done by the Comodo services that neither can be stopped) and copying over the files manually. This problem didn’t exist with version 6882. In short Comodo protecting itself from it’s own selective modules…!

try install version beta : Comodo Forum


Setup Details:
In order to install online setups, please ensure you have following entries in Windows hosts (c:/windows/system32/drivers/etc/hosts) file:
Code: [Select]

Hello !Wolverine!,

Thank you for reporting.
This is an known issues in this version and it’s fixed in the latest Beta Versions.So Could you please check with latest CIS v12.2.1.6950 Beta 2 (or) else please wait for the stable release some of the known issues are fixed in the upcoming stable release and in future you don’t have this issue again.

Note :

  1. Before installing CIS please use the latest Comodo Uninstaller Tool (Select upon your windows bit) for the clean Uninstall of the CIS.Then install and check.
  2. While installing Beta version on your PC Please add the entries in Windows hosts (c:/windows/system32/drivers/etc/hosts) file.

Kind Regards,

today already 06 May 2020 but the issue is still not resolved. I had to remove the current version of CIS and install the previous one without the bug.