Cisco VPN Client and Comodo Firewall Blue Screen Problems

Cisco VPN client installs ZoneAlam Firewall and thus it conflicts with Comodo Firewall causing BSODs.

1 - Search your computer for vsdatant.sys and vsruledb.dll files.
2- Delete these files
3- Reboot your PC

Thanks for that information Egemen I will make this topic sticky so others who may have this problem in the future can see this topic and see the solution.

I was having the same reboot/BSOD issue with Cisco VPN. So I found and deleted “vsdatant.sys” from my PC, then rebooted. (I did not find the other file mentioned) This did indeed stop the reboot/BSOD issue, however Cisco VPN will no longer accept my password to connect to my company. When I reinstall the file it does… :frowning:

Does this mean I am stuck using Zone Alarm? Is there another fix, or is this issue being looked at?

Thanks in advance,

Unfortunately you are stuck, as Cisco have licensed ZoneAlarms firewall engine to embed into their VPN client. When you start the VPN client you are invoking the ZoneAlarm engine as well as it is monitoring the data flow over the VPN connection.

Two firewalls on the one system is asking for trouble.

Sorry to be the bearer of bad news.

Ewen :frowning:

Unfortunately you are stuck, as Cisco have licensed ZoneAlarms firewall engine to embed into their VPN client.

Bummer, I really liked everything I saw about Comodo, but I doubt I can change my companies mind about Cisco VPN. (50,000+ employees) :-\

But I do appreciate an honest answer.

Thanks. :slight_smile:



I have a problem with my VPN-Client. After the Instalation i’m not able to see my Computer in the network and other people even don’t see me.
I am althougt not able to connect me with the VPN-Server. Vpn starts and is contacting the security gatway but didn’t connect. Angry

I have a Laptop where i have installet Comodo and VPN too and there are no problems. So whats wrong with my computer.

By the way, i had have the problem with the blue-sreen by the last instalation, but after del vsdatant.sys i was able to install VPN Correct. But i don’t have found vsruledb.dll to delete too.

Before using Comodo i have used Norten Personal Firewall (maybe this is an indikation).

Hope somone can help me and sorry for my very bad englich.

P.s. Since today a friend of me has the same problem. Ok network still works but vpn doesn’t conect.
Problems in Comodo Softwear???

If I boil it down to the simplest thing to try first… When joining a VPN network, you are typically assigned an IP address while on that network, and typically that assigned address is not in the same range as what you use at home… Therefore, if you want to allow traffic to flow through a VPN network, it’s LAN address range would need to be added into the network rules, done easiest through the Define a new Trusted Zone wizard.

First up, Cisco VPN client needs to enable either local LAN access or use Split-tunneling to enable browserlistings. With both these options disabled, your computer is essentially a part of a different network once the VPN client is active. All network traffic will then pass through the VPN gateway instead. If you can’t reach the VPN gateway, check your firewall to ensure outbound UDP 500 for IKE. And, if possible, that you can PING it. Cisco VPN also requires that you use the proper group Authentication before actually being able to connect successfully. So verify that the host IP is correct and the authentication is OK.
If you’re unsure which of the phases fails, start logging the events :wink:

Furthermore, there’s no ZoneAlarm client either packed or shipped with any Cisco VPN client and never has been. Nor is it embedded as mentioned. There was suggested that Cisco would implement BlackIce back in rel. 3.6, but this never panned out. Guess they didn’t come to a mutual agreement :wink:
If you look closely, there’s an option called “Stateful Firewall (Always on)”. This is not to be confused with a full blown firewall. It’s just a packet inspector licensed by Checkpoint (Zone Labs LLC) to prevent inbound routing over VPN. You may leave this off (default) or turn it on for added security.

As for the 2 files mentioned, vsdatant.sys I beleive is shipped with the OS. It’s datestamp makes me beleive it’s part of the XP-sp2 firewall and came with the servicepack. Never seen it included with the Cisco VPN client.
The vsruledb.dll is nowhere to be found on my computer, so this file obviously came with another program (previous ZoneAlarm installations perhaps?). I’ve logged and gone over the files in use by the Cisco VPN client, and neither of the files mentioned are being accessed. Which makes me believe they are redundant files, or part of another application.

I’ll wrap this up by saying that I’ve never experienced a conflict between the Cisco VPN Client and the Comodo Firewall (Pro). Only time I’ve seen a BSoD related to the VPN client, is when my Company IT-Policy forced an installation of Nortel’s VPN client when the Cisco VPN client was already installed. Sometimes reading the manual really helps :wink:

I applied the bat file by

REM * Author: dianneg, modified by Zero-Point (2004.10.26)

found at:

and it fixed my problem with the Cisco VPN Client BSOD on connection. I recently removed the Cisco Client and reinstalled a new version and when I ran the VPN client my BSOD came back. The Cisco client reinstalled the VSDATA.DLL and VSDATANT.SYS (my .bak created by the above fix were there also).

I reapplied the bat file and my BSOD are gone.

My OS is XP SP2, Cisco VPN Client BETA

I looked at both VSDATA.DLL and VSDATANT.SYS with a hex editor and they both have reference to Zone Alarm. VSDATA.DLL has “Copyright 1998-2005 ZoneLabs LLC.” embedded.

Hi there,

I solved all my VPN problems by installing the Cisco VPN client BEFORE installing the Comodo firewall. Hope this helps!