CIS8 interferes with iOS update\restore operation from 'iTunes' [M1393]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes. Every time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Connect iPad \ iPhone to the PC & Run ‘iTunes’.
Link : iTunes - Apple
2: Update or Full Restore from ‘iTunes’.
3: At a certain point, before completion, I get ‘error 3014’.
One or two sentences explaining what actually happened:
‘iTunes’ is not able to update or restore iOS if CIS 8 is installed.
One or two sentences explaining what you expected to happen:
There should be no update\restore errors.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
I’ve uninstalled CIS and the problem does not persist. I’m experiencing this issue only with CIS 8.
Full dump of ‘iTunes’ when the error message is displayed : Dropbox - Error

Exact CIS version & configuration: | Configuration: “Internet Security”
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5 or CIS6?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 x64, UAC : Disabled (via registry), Account type: Administrator, V. Machine: Not used
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Malwarebytes Anti-Malware Free

[attachment deleted by admin]

I When you connect the phone/tablet, drivers are installed automatically (eg first time connection) ?
II Do you have to install drivers separately, possibly from ‘iTunes’ ?
II.1 Downloaded after phone/tablet connection (trough ‘iTunes’ directly) ?
II.2 Not downloaded, but installed directly from ‘iTunes’ directory/package/installer?
II.2.1 Upon installation, is anything downloaded from the Internet?

Thank you.

I. Yes, drivers were installed automatocally.
II. No, drivers were installed by the system.
II.2.1 Upon update \ full restore, Itunes downloades latest IOS (that part goes without problems), then switches Ipad to recovery mode, and gives error 3014, leaving Ipad stuck in recovery mode.

P.S. Sorry, but didn’t really understood questions II.1 and II.2

  1. Please check if this issue is fixed in version <>.
  2. Try to replicate the issue once again. When the application displays the error message, create a full dump with KillSwitch.

Thank you.

The error still occures.

Itunes.exe full dump

One more thing, if possible, could you please try to uninstall MBAM Free? Does the issue persist?
I’m asking this because there is a similar conflict that interferes with certain applications.

Also, please attach a system information file. (run > msinfo32 > save)

Thank you.

Problem persist with MBAM free uninstalled.

[attachment deleted by admin]

I’ve made some edits. Do these modifications reflect your report?

Thank you.


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.


I have had the same issue as described below by Maniak2000.

After playing around with several different set-ups, I have found that when ‘Website Filtering’ is unchecked that updates for iPhones and iPads works without errors :-

[attachment deleted by admin]


Thank you for the work-around. I’ve linked your information in the tracker.

Thanks again.


This problem is still occurring with CIS Version, iTunes Version 12.3 on a fresh install of Windows 10 32bit Home. No other software installed.

3: At a certain point, before completion, I get 'error 3014'.

The error occurs after iTunes has extracted the Update Download and the Phone / tablet enters the update phase.


Sorry to hear that, Dolphin66.

I’ve updated tracker data.
Thank you!

It would be helpful if someone could use Wireshark or something similar to capture network activity while replicating the issue~ we could gather a list of addresses to be whitelisted.

Please check again with version thanks.

Please check with Comodo Internet Security V10.0.0.6071 Beta thanks.

Please check with thanks.

Please check issue with CIS thanks.