CIS7 - Empty Virtual Desktop

Can someone tell me why is Virtual Desktop now entirely empty? During beta for CIS7 i remember i had bunch of stuff from my nromal desktop on the VD. But now, empty. Also the browser that i start inside is empty. Before, it was sandboxed but with all the addons and stuff. Am i missing something here or have they changed something for final version of CIS7 ?

I don’t really use the Virtual Desktop so I’m not sure about what was there before and what is there now and what is supposed to be there etc, but it doesn’t sound right that the browser doesn’t have any add-ons, have you tried resetting the sandbox to see if that fixes it?

Basically when the browser is sandboxed then the data is carried over from the real system to the sandbox, however this will only be done if it was not previously sandboxed, so if you sandbox the browser and then make changes to it in the real system those changes won’t be seen in the sandbox until you reset it, so it could be that something got corrupt in the sandbox which made the browser itself reset which is why it’s empty… I honestly don’t know, I’m just speculating in a possible cause of the browser issue, I’d recommend resetting the sandbox to see if that makes any difference.

I noticed the same thing: there are only few program links in the VD now…all files, folders etc that are on the real windows desktop are gone…why?

Virtual Desktop is working fine for me on Windows 7.

I’m using Windows 8.1 64bit and this has only changed with CIS7 final release. before, even in CIS6 and CIS7, there were bunch of files present inside from the actual host desktop. And since there was no mention of this change, it just feels confusing. And kinda useless. I mean, for banking i’m using random generated very long full ASCII pasword which is stored in LastPass with double authentication and just as complex password. Typing it in by hand every time is just not possible and if i can’t have Lastpass extension inside the browser (within Virtual Desktop), i just can’t use the feature. Before CIS7 Final, it worked, now it doesn’t.

I’m running windows 7, and facing the same issue…i don’t use VD very often, but actually this thing makes it useless…a VD should give me the chance tu use every feature I have on the real one in a virtualized environment…otherwise there’s no point in having it…

Hi Guys,
As Sanya suggested, have you tried resetting the sandbox?

I tried everything, included reboot…then i had a doubt…what about removing “desktop” from the protected data folders list?? And…I couldn’t believe it…now it works!! I bet even Rejzor added desktop to protected data folder.
BTW…ovviously this thing has to be fixed…

Yes, i’ve added my entire documents folder into protection and desktop folder is also in there. And since i’ve added user profile as well, browser didn’t work eitherw ith its addons. The functionality makes no sense to me. If youw ant to protect your sensitive data from leaking to the sandboxed apps, they are unusable in Virtual Desktop. If you don’t, they work inside VD, but they are exposed to auto-sandboxed apps. Not cool.

These things should be completelly separated as far as configurability (and protection) goes. Data protection should only be limited to Auto-sandboxed apps and not to apps sandboxed by the user within Virtual Desktop. It’s a completely separate thing so i have no clue why it shares data and configuration between auto-sandboxed stuff and Virtual Desktop. I mean, auto-sandboxed apps and those in Virtual Desktop should be physically separated within virtualization realm. They should NEVER share sandboxed data. Which from what i can see is the case.

So, anything nasty that might be sandboxed by the auto-sandbox may leak a data from your Virtual Desktop, because apparently they share eachothers virtualized space unless if you block it with Data protection, in which case you’ll protect the data from leaking, but you’ll make that same apps that are protected unusable inside VD. That’s not cool at all and kinda defeats the purpose of using VD in the first place. I mean, from what i can understand, you can have almost infinite number of separated virtualized “worlds” on todays HW accelerated virtualization powered CPU’s.

Also, this is probably the reason why THIS thing happens: if you leave shared space folder link on the desktop (it’s put there by CIS by default!), and then add the desktop into protected data folder…;msg744862#msg744862

I had to reinstall CIS from scratch, and then everything went smooth, but I didn’t put desktop in protected data folder immediately (as I did before)…so I thought the problem depended on an installation issue. Then I put again desktop in PDF, and again the same problem. This thing definitely needs attention by devs.

Could some dev/mod take care of this topic? seems that the issue explained above is quite important…

The Protected Data Folder blocks everything in the Sandbox from even being able to see the files in the folders specified, that is its purpose. Could you perhaps enlighten as to what you wanted to happen instead?

Regarding having it work only for automatically sandboxed applications and not manually sandboxed applications, I personally don’t want this behavior because I right-click and select to sandbox dodgy applications instead of having it set to automatically sandbox applications (I use HIPS instead of BB), hence I want it to be active for applications I have manually sandboxed.
A possible solution would be the ability to set up exceptions/exclusions for specific applications so they can still read the data while sandboxed.

Also remember, if you believe this is a bug then you can report it as a bug, if you believe it is desired to change the way it works then you can create a wish. If neither of these are created then there is a close to 0% chance this behavior will be changed, of course miracles can happen. 88)

The main issue is that if you add “desktop” and “documents” to PDF, run the browser in FV mode, and try to save something in Shared Space Folder (SSF), then you can’t find SSF!! Infact, the browser doesn’t see it, because is runnig in the sandbox and can’t recognize files/folders included in PDF (SSF is put by CIS on the desktop by default)…also, if you start Virtual Desktop, it can’t see most of the folders/files on the real desktop…and therefore you can’t use them in the virtualized session…
BTW, try by yourself: put desktop and documents folder in PDF…then open VD, and see how your desktop appear in the virtualized environment. Tell me if, in your opinion, this thing makes sense or not, and therefore if its the case to fill a report as a bug, or wish… :wink:

I’d just like to point out that the Shared Space isn’t actually located on the desktop, what you see on the desktop is a link to [b]C:\ProgramData\Shared Space[/b] however ProgramData is a hidden folder. I can however see how this would be an issue since I assume most users get to the Shared Space through the desktop shortcut.

Based on the knowledge of what the Protected Data Folder is supposed to do (hide files from the sandbox and effectively block read/write access) it does make sense that this happens. I mean based on the current implementation it does make sense that VD can’t see the desktop if you add it to the PDF which to me doesn’t look like a bug but rather an unhappy(?) consequence of the feature.
Now I’m not saying that it makes sense to me that it should be the intended behavior.

To me it seems you want it to do something something that it’s currently not intended to do so to me it seems like you want to make a wish however what that wish would be for I don’t know, you’d have to decide that yourself. (I don’t understand exactly how you want it to work)

But then again I’m not really a developer of CIS and it’s not like I’m never wrong or anything. This might actually be a bug, I couldn’t possibly know that but to me it looks like intended behavior which has some consequences.