CIS won't install, breaks internet connection

Hello, I have a problem installing CIS.

I download the installer and run it, but the installation gets stuck for some reason, I remember it stuck at 81%. I tried waiting but it took too long so I cancelled the installation. But then I also noticed I can’t connect to the internet anymore.

So I went to Control Panel > Network Connections and right-clicked Local Area Connection > Properties

Under ‘This connection uses the following items:’, I saw ‘COMODO Internet Security Firewall Driver’, I think that was the name.

I uninstalled it and the internet started working again. I tried re-installing CIS but it had the same result.

Could anyone help, please? How can I successfully install CIS?

Please try following the advice I give in this post. Let me know how that goes.


Unfortunately that can’t help me, right now my PC is re-installed clean but the problem used to happen to me even before I re-installed it. I wasn’t able to install CIS since then. But on another computer I could install it fine. Is the problem with my hardware?

Did you try running the removal tools in Safe Mode? Also, which version of Windows do you have?

No, but I don’t think it can help me if CIS always fails to install even on the newly re-installed computer. I use Windows 7.

If it failed once it could have put files on the computer that are interfering with subsequent attempts to reinstall. Thus, running both CIS removal tools in Safe Mode may be able to get rid of those files and allow CIS to install fine after rebooting the computer.

It’s at least worth trying.

I tried it, but when trying to re-install CIS it had the same result as before.

Do you have any other security programs installed?
If not what about maintenance software?