CIS - Windows10 CU - Block All Inet and Desktop Icon[M2222]


i’ve found two issues with my CIS.

i’ve no CIS shortcut on the desktop.

1- Change Firewall mode to “block all”
2- desktop icon it’s created automatically
3- I change the Firewall mode back to "Custom Rules " or other mode
4- no internet connection and adapter need to be switched off/on

in resume it’s the desktop icon auto creation and the unavailability to have internet after switch from Block All mode.

Windows 10 1703 (build 15063.138)

BTW: While running the Diagnostic i’ve got the message that CIS have found some issues and couldn’t be fixed and size it’s +30 how can i provide to you?

Hi Pepi0,

Desktop Shortcut issue will be resolved in upcoming release.

the unavailability to have internet after switch from Block All mode

You can send the diagnostic report by using any cloud storage like google drive or mega and provide us the link.

Kind Regards,

Hello PremJK,

thanks for your reply, i’ve followed the topic about the desktop icon, sorry in advance for the duplicated seems i didn’t look well before create it.

about the Diags i’ve uploaded to Gdrive:

let me know in case of any issue


Hi Pepi0,

Thanks for providing the file. We will get back you soon.

Kind Regards,

Please check gain with Desktop icon should be fixed for your first issue. I could not replicate second issue of switching from block all mode to safe or custom ruleset mode.

what type of connection are using to access Internet? needs a bit of context.

1- set block all conections on CIS
2- after 20 aprox seconds the network icon on the task bar show the alert (probably due the network connection locator cannot do the ICMP)
3- change the setting to Safe Mode / Custom ruleset
4- Internet connection doesn’t work and it’s needed to set airplane mode and enable connections once again

PS: After last update i noticed that seems as if adapter get disconnected from the WIFI connection, however after around 1 minute adapter re-connect to wifi so might be this issue was fixed (?)

Please check issue with

Please check with thanks.

Please check with Comodo Internet Security v10.0.1.6294 thank you.