CIS wierd behaviour and I can't uninstall it

Hi everybody, I never had any problem with CIS since a few weeks ago. Probably the problems started right after upgrading to Windows10 21H1.

I noticed that sometimes, when I turn on my PC, I can’t run the applications from the Windows 10 task bar. It says that I don’t have permission to access to the app or the folder or something like that. At the same time the CIS user interface reports the “At Risk” message and freezes for 1 or 2 minutes and then restarts.
In the windows events viewer I found a lot of the following errors: “Event 7034, The COMODO Internet Security Helper Service terminated unexpectedly.”

Then I discovered that CIS didn’t behave as usual. I’ll try to explain with some attached images.

Image01 : The firewall section shows no connection. This is clearly not true because I’ve various programs connected to the internet.
Image02 : The firewall log shows a lot of rows without any application name and source and destination IP. As you can see there are a lot of “Ask” actions, but it never asks me anything. So I don’t know if there is any attack in progress or a malware.
Image03 : The firewall log shows a few rows with strange application name: they seems to be chinese ideograms, but they can simply be some dirty memory. If I try to export those rows, they are not exported.

I wanted to try to uninstall CIS and install it again. I followed the guide Comodo Forum but when I tried to uninstall, the uninstaller said that some problem prevents the execution of the uninstallation without specifying which problem. I then ran the Microsoft Program Install and Uninstall Troubleshooter. It told that it fixed some problem in the registry and invited me to execute again the uninstall procedure. Unfortunately now CIS is not in the list of anymore and I can’t run the uninstaller anymore. It’s not even in the troubleshooter list anymore where, if I select program “Not in list”, it then wants me to insert the product code.

Now I don’t know which way to go…
I searched in the windows registry and maybe I’ve found what seems to be the MSI product code but ha can I be sure ?
Otherwise can I directly run the ciscleanuptool without uninstalling the product first ?

BTW I executed various virus scans, even with other antiviruses and no infection was found.

What’s my best option to repair the CIS installation ?
Thank you!

Which CIS version are you using?

Probably you have encountered this bug : Invisible dialogue and a mystery process

Yes you can run the CIS Cleanup Tool w/o uninstalling first and make sure you follow the reboot instructions . . . . It should clean out any remaining traces and then you can try a Clean Install again

Thank you very much for your fast reply.
I’m on version I’ve seen that there’s a most recent version ( ?) but the automatic upgrade doesn’t seem to know about it.
I started reading the thread you pointed me out and it seems exactly the same problem.

Thank you for your prompt reply.
Reading the thread suggested by Ploget, I shouldn’t be worried by this problem. It’s only annoying, am I right ?

So, if I understand correctly, the suggested procedure to solve the issue is the following:

But this makes me thing that the bug is not fully solved in the 7098 version, the one I’ve now.

Any other advice ? Should I wait for the automatic update ?

I would say to completely uninstall first using CIS Cleanup Tool and then do a clean install with the latest version 8012 found here: Comodo Internet Security 2020 v12.2.2.8012 Released

Personally I prefer to download and use the offline installer to install CIS whenever I have to.

The latest version is stable and should solve your problems with a Clean Install. This has not been released through the update channel for some reason, but can be installed from the Comodo site online, or offline by using the forum link: Comodo Forum

Thanks to both of you Ploget and CISfan.
I’ll try to uninstall with the cleanup tool and install the latest version. Finger crossed !

So I have to execute the ciscleanuptool_x64.exe and then the removal tool with Windows restarted in Safe Mode, right ?

There are many names for the same thing unfortunately, you only have to run ciscleanuptool_x64.exe in a normal Windows session and follow the on-screen instructions presented to you.

Here you can download and read more about ciscleanuptool_x64.exe : Official Comodo Uninstaller v3.1.0.45 Released

Just use the CIS CleanUp Tool . . . . that should be all that is necessary. Starting in Safe Mode is also not normally necessary

Hi everybody.
Just to confirm that a few days ago I used the CleanUp tool to uninstall the malfunctioning CIS. It took a couple of restarts to complete the operation.
I then reinstalled CIS and everything is perfectly working now.

Thank you for the support!

You’re welcome . . . glad everything worked out for you :-TU