CIS Virus database upodate will not run [RESOLVED]

Any one else having problems with the virus update not running? Internet connection appears to be the problem however my internet works fine on that machine for everything but the database virus update

Suggestion for this one problem machine is the internet connection needs to be checked HOWEVER the CIS program itself happliy updates the CIS update and currently reports no updates are available

For the Virus signature database it will not update and shows the db no first downloaded with the instal Currently 487 ( I reinstalled recently and this is the only way I can get upodates close to reality)

If I knew the processes involved I might be able to self help!! I tried copying the C:\Program Files\COMODO\COMODO Internet Security\scanners\bases.cav however this did not seem to solve my current number problem so I guess there may be other files involved in the update process that I have failed to find

Anyone been able to overcome this one…seems I am not alone from comments on the forum but can’t see anyone posting solutions

I am not behind a proxy setting at all

Have 4 computers working on a network perfectly just the 5th one will not update as described

Hello Brockie, Sorry about the troubles.

Did you ever use CIS RC 2?


Yes I did and I updated at first to the current version then reinstalled “clean” after uninstalling lastest version cleaning up registry as best I could with Comodo Registry Cleaner and also CCleaner

Thank you for looking at this for me


I think you should get an update today. If not try - Open CIS GUI - Antivirus - Update Virus Database manually and it should get updated to version 494.


Thany you for your response…neither the automatic update nor your manual suggestion will work and update the virus side of the update on this one computer.

Truly I have tried all the normal tricks I know but this one machine has me bluffed.

The program update updates fine so it can’t be the internet connection which the message window suggest

Thank you for your response… much appreciated


Have the same problem here. Does not want to update (Manual/Auto) the after a wile it says updated. Line is working fine and this is happening on two pc’s . One has now updated it self and the other does not what to. Looks like timeouts from the net . Ping to is 220ms avg . Ping to is 200ms avg. So it looks like a server problem.

Please check this out

Make sure the configurations are correct.

All is according to this page. The systems did work last week (Friday) but does not get update as from today.

If you haven’t done any new program installations between Friday and today, you can safely try to restore the computer to Thursday. This can be done by

Start-All Programs-Accessories-System Tools-System Restore in XP.

You can again check for virus database updation after restoring the computer to an earlier time to check whether it solves the problem. If you have installed any new programs in between, it will be lost, hence, do this only if you have not installed new programs. (If you are a techie / accustomed user, this could be an unnecessary suggestion).

Does not help. Have done clean install on laptop with XP SP3 and loaded comodo . Does not update aswell.

When I try some of this links directly from the browser thy work perfectly. “

My last suggestion :- check Comodo Internet Security-Firewall-Advanced-Network Security Policy to check whether there is any inadvertent blocking of CIS. By default it is greyed out to permit CIS internet access. Still just check out.

Also, you can check defence+ policies for CIS files. These are also greyed out by default. If this also does not help, over to experts in the forum.

Did you check for all the subkeys 0-4? That is crucial but not mentioned in that thread if I recall correctly.

This corrected the AV update problem for me. On my Vista Home PC I had the wrong values in the subkeys and on my XP pro PC I had the wrong value in subkey 0 but 1 thru 4 had been correct. Once I changed to the correct value, all update without a hitch.


Have reinstalled CIS AGAIN and checked all the suggested Registry values… they were and still are all correct.

Still no virus database update…starts to run …gets to 5% and falls over with the “check internet connection …” message

Tis frustrating. Have copied the virus file from another machine and it reads the latest so looks like I am going to have to do this forever or change my protection to another company

Brockie I feel the same , it was working on the previous release now on …427 it does not. I’m sitting with the same problem here , and are swithing back to other AV untill this is corrected.


Delete this post.