CIS v7 problems

This is further to the post I made yesterday, found here:;msg763678#msg763678

Not sure if it is the wrong place to put it, but it seemed like my problem was relevant enough to what the OP was experiencing and thought it may help diagnose the problem.

As I explained in that post I am now experiencing some serious problems with this security suite that is slowly rendering my laptop unsuable. Prior to installing CIS I was using a different security suite and my system ran flawlessly. But after installing this security software…ugh

As I have already explained, things seemed to be operating fine until I tried to perform a Windows Update for Windows 7 x64. CIS brought up a notification saying that a trusted application was trying to access a protected COM interface (or something similar) and that I can safely allow the action. WHY It would halt everything on my laptop and tell me that this action is SAFE is beyond me. However, this caused my entire laptop to lock up. I couldn’t close the notification, I couldn’t close or open any other windows, I couldn’t use CTRL-ALT-ESC to access TaskManager (even though I always have this open).

This lockup lasted for about 20minutes where it suddenly decided to process a couple of my mouse clicks that I had done on the CIS Notification and I had a brief chance to see that there were other alerts about access to a protected COM interface…right before it locked the entire system up again.

The ONLY way to get out of this is to hold down the power button and do a hard reboot…something I am seriously unhappy with having to do. So far I have had to do this three times: Two of the occasions were due to Comodo locking the system after presenting me with a notification about some safe event that I can safely allow. The most recent, about 15minutes ago, was due to Comodo dragging my entire laptop to a crawl until it eventually locked up completely after a notification about CMDAgent trying to open CIS when I tried to open CIS in order to check what it was doing to kill my system.

I installed and configured CIS v7 using the guide from this forum. Prior to installing I had completely removed my previous security software (Kaspersky Internet Security) via their removal tool in safemode. My system was (and had better still be!) 100% clean and operating flawlessly before installation of CIS v7.

My current settings for CIS v7 is as follows.

Proactive Security.

Realtime scan enabled.
Scan optimization enabled.

Enabled and using “Safe Mode”

Behaviour Blocker:
Autosandbox of unknown applications (partially limited)
Detect programs that require elevated privileges.
Show privilege elevation alerts for unknown programs
Enable Virus Scope
Do heuristic command-line analysis for certain applications
Detect Shellcode injections

Enabled and using “Safe Mode”
Enabled automatic detection of private networks
Enabled trustconnect alerts (unsecured wireless networks only)

Fire Rating:
Enabled Cloud Lookup
Analyse unknown files in the cloud by uploading them for instant analysis
Trust applications signed by trusted vendors
Trust files installed by trusted installers

I would greatly appreciate any help that can be given to get this software to work and I will provide any other required details as necessary. This is currently my “review stage” of the software before moving the rest of the household over to a new security suite and I can’t say I’m impressed with how CIS is “protecting” my system so far.

Maybe you just missed the options of “enabling learning / training” mode(s) before restarting your (hopefully) clean sys?

Just a thought. Been using CIS for quite some years. Love it. >:-D

Kind regards, REBOL. :slight_smile:

I have read and referred to this help page here: Comodo Internet Security v.7.0, Antivirus protection, Firewall Software | Comodo

I was actually reading through this on numerous occasions before even settling on using CIS as I was viewing the pros and cons of what was currently available for security suites. My aim was to achieve the highest protection while having the minimum of alerts/notifications/etc, while having the best performance before doing the switch for the rest of the household. I was referring to this help page while installing and configuring according to the guide I was following.

I hadn’t had to configure or tweak anything for almost a week. Notifications occured as expected. I would assess and then select the required action. The notification would close…perfect. Fast, simple. Maybe a little too indepth for the rest of the household, but I was looking into that.

The ■■■■ hit the fan during the most recent Windows Update for Windows 7 x64. They updates were downloaded but didn’t even manage to get past the installation of the first update before CIS alerted me that a safe application was trying to do a safe action and that I could safely allow it (…facepalm). This appeared to have been triggered by the trusted installer but CIS completely locked up my laptop, as I described.

I wasn’t at all happy with having to do a hard reset in the middle of a windows update…

After the restart the updates were able to install without a hitch, but CIS has been screwing over my laptop ever since. I hadn’t changed anything, hadn’t tweaked anything. It has been amost a week since the last tweak I had done to CIS and I had been using it fine until it decided to take a dump all over windows update.

The post I linked to was from another user that appeared to have dealt with an almost identical problem as I now am (and maybe still is), so I know I am not the only one.

What you describe is similar to what I experienced, regarding locking down or alerts.;msg762277#msg762277

If you can, take your sensitive data off the drive, dban/autonuke the drive, partition it with gparted, about 60GB for the OS on C (to get the exact GB you want to show in Windows Explorer multiply the amount of GB with 1034), the rest for your Data on another partition, D, etc. Prior to that of course get the drivers for your laptop and get the OS you want, possibly with the Service Pack already on it. Additionally get macrium reflect free version and make an image first thing when you installed the OS, so you always have a clean image and your data on another partition, in case some software is bogging the system.

Then go about installing Comodo again, I am sure it will run fine. I think what messed up is the OS update perhaps the Firewall did not take that well. Not sure, just trying to offer some very basic help. Just set up a system from scratch and so far things are running fine while before I had issues.

Or try this perhaps: Comodo Forum

Thanks for the reply, TechnoSoul.

It does seem a lot like what you described in your thread, but when it happens to me it locks up the entire system. It quickly goes from being unable to close the alert or select an action, but still being able to max/min windows, to the entire system locking up completely and forcing me to do a hard reset.

I did do a complete clean out of my previous security software, complete with removing registry entries and folders on the drive prior to installing CIS v7. I’ve not had the issue rear its ugly head again since my last post, but I’m now constantly dubious of when I may get an alert and if it is going to lock up again due to it. Seems pretty flaky.

I may go ahead and try a complete reinstall of CIS and see how it goes. I don’t have the time to do a clean O/S install, but could set aside a few hours to clean uo and reinstall/update.

Not quite sure what it is that triggered the problem but it seems fine…for now. I’ve not had any alerts since, so that may be why it’s not locked up. Odd that this is the only time that I’ve had a security suite not like a windows update. Worked fine with my previous one.

Anyway, thanks for replying and providing the detailed info. I’ll refer back to it if and when I get to testing and reinstalling.

Just for thought, though I do not have any 64 bit systems, I used to experience a similar issue to what you describe. I first experienced this issue when clean installing a windows OS (both xp and vista), then installing comodo, and then attempting service pack updates. The problem would not recur if CIS was uninstalled, or if the service packs were installed prior to CIS installation.

Also, I have experienced this on occasion on XP, Vista, and 7 OS’s in the past, mostly during patch tuesdays (and not every time though). It seems my issue was, after patch tuesdays, and restarting my system, the Windows Malicious Software Removal Tool would auto run at startup, and IMO, conflict with something in CIS and cause the issue (very similar to what you describe), causing me to force shut down, and usually function normally after restart.

I have since never checked the installation of the Windows Malicious Software Removal Tool during Windows updates, and knock on wood, have not experienced the issue since doing this.

Hi MatrixShield,

if you look at other topic, we are a lot to face this issue. In fact when you launch software (it depends which), CIS is taking PC ressources for minutes.
If you wait, then you will have the hand back normally.

We are waiting for a patch to correct the issue.