CIS scan crashing computer

Hi folks,

I’ve got a Windows 7 Ultimate 64-bit Dell Studio machine that came with McAfee Security Center preinstalled. The thing finally expired, and as I am not a fan of McAfee, I was going to switch over to my old standbys (Avast Antivirus and ZoneAlarm), but then I stumbled across’s latest internet security software test results.

Based on those results, I decided to download Comodo’s free Internet Security program instead. It installed all right and immediately wanted to update the virus database, which is fine. So I’ve got CIS 5.3.181415.1237 with virus database 8033.

Next it wanted to do an initial full scan. I said OK. But then after about 40 minutes it stalled (that is, it got stuck on a file but the timer kept going) and crashed my computer … although I could move the mouse and click on stuff, I couldn’t access any other programs, I couldn’t exit out of the scan, I couldn’t open the start menu, I couldn’t access CTRL+ALT+DEL or anything. My only option was to restart the computer manually.

This has happened every time I’ve tried doing the initial full scan since. And although it doesn’t always hang on the same file, it does always seem to hang after about 40 minutes. EXCEPT, I just tried doing a scan on a single folder, and while that went through OK, the computer got stuck and I had to manually reboot again shortly thereafter.

This is very frustrating because this computer never crashes. I practically never have to force-quit anything in the Task Manager, and I never have to manually reboot. This is the most stable computer I’ve ever had. Until now. It would appear that I cannot scan the computer with CIS viruscan.

Should I just uninstall the viruscan part of CIS and use Avast Antivirus instead?

Thanks in advance.


CIS is crashing less these days then in the v4 period. If there are only a few files that make it crash you could exclude those files.

Other than that you could try another AV scanner for your weekly scan. The on a access scanning of CIS is fine.

It would greatly help Comodo if you considered to file a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Also follow How to determine which file is causing a manual scan to hang to determine what file was causing the scanner to be hung. Please add this information to your bug report.

I have the same problem and like the first post says, it won’t let me multitask while the scan is running… so, my solution would be, RUN THE SCAN, DO NOT DO ANYTHING UNTIL THE SCAN IS DONE…

I have the same problem, but my win 7 64bit just crashed and the computer shut down. When I scanned all the disks individually, all were fine! Never seen that for other AV software.