CIS randomly stops working

I run CIS with D+ (set to paranoid) but without Antivirus ,it happens that once every 4-5 days on average (since i updated to CIS) the program ,usually 20-30 minutes after boot, just warns there was a fatal error and it’ll be terminated. Then CIS icon disappears and i have to revive comodo from start>allprograms>CIS, after which it works fine for days,only to happen again all of a sudden.
Thinking about it, it did it since this latest CIS install.
I have been running the same programs for a long time with no issues, i dont know what to do…perhaps wait until next release,which seems to me imminent,and perhaps try it including the antivirus as well…
Luckily there’s a router taking care of these really occasional lapses,still its not a perfect situation…
My set up: XPPro,CIS D+,PrevXEdge,Antivirfree,Geswall also free
anyone can suggest anything?

Running Miscellaneous > Diagnostics is worth a try.
Or you can try an uninstall and reinstall. Remember to export your settings if you do decide to.

Also, you can check your Firewall/D+ logs and maybe post a screen shot of the error message when/if you get it again. :slight_smile:

Thanks for replying FaZio. I already tried diagnostics and logs route to no effect, diagnostics find all is ok and logs show nothing to my knowledge (but as soon as it does it again i will post here just in case). Reinstall is my last option,after it will do it one more time to enable me a glimpse at logs.
It could well be another program like Geswall or PrevXEdge as it occurs very near to boot.

It finally did it again,it seems dwwin.exe/drwatson are involved,but i cant see exactly why:
see attachments.

[attachment deleted by admin]

Did you try a reinstall?

dwwin.exe and drwatson.exe are part of Dr. Watson for Windows utility.

This program is an error debugger. It gathers information about your computer when an error occurs with a program (i.e. CIS). For this reason, I suspect something else is causing cfp.exe to crash, and Dr. Watson is just trying to gather info on it. When an error is detected, Dr. Watson creates a text file called
“Drwtsn32.log” most likely in “C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson”.
Perhaps this log could tell the problem of the fault.

I couldnt find Drwtsn32.log,perhaps was cleaned up by CC or jv6, but i have reinstalled anyway ,even not using previous cfg and starting all anew, and,up to now (4-5 days) all is ok. I optimistically deem it is solved this way, but will inform if otherwise-looking at logs next time. Thanks for your help FaZio.