CIS password protection doesn't work when removing firewall / AV [Issue Report]

The bug/issue
1. What you did: I set password for CIS and opened Add and Remove components. Then I selected to uninstall firewall and clicked Next and Change.
Setup Wizard started to remove the firewall and soon it asked for the password. I clicked Cancel on password window. Then the setup wizard continued and removed the firewall although I did not type the password.
Now I rebooted and firewall was gone.
2. What actually happened or you actually saw: Password protection didn’t work.
3. What you expected to happen or see: I expected that if the password window is closed then the setup wizard would not uninstall the component.
4. How you tried to fix it & what happened: -
5. If its an application compatibility problem have you tried the application fixes here?: -
6. Details & exact version of any application (execpt CIS) involved with download link: -
7. Whether you can make the problem happen again, and if so exact steps to make it happen:

  1. Install CIS and set a password for it.
  2. Open start menu and click All Programs.
  3. Select COMODO folder and open Add and Remove components.
  4. Click Next and Change.
  5. Untick Firewall or AV.
  6. Click Next and Change.
  7. Setup Wizard will start to remove the component you selected.
  8. Soon there will open a window that asks for the password. Click Cancel on password window.
  9. Setup Wizard continues to remove the component although password was not given.
  10. Click Finish and reboot.
  11. Component you selected is now removed.
    8. Any other information (eg your guess regarding the cause, with reasons): -

Files appended. (Please zip unless screenshots).
1. Screenshots illustrating the bug: -
2. Screenshots of related CIS event logs and the Defense+ Active Processes List: -
3. A CIS config report or file. -
4. Crash or freeze dump file: -
5. Screenshot of More~About page. Can be used instead of typed product and AV database version. -

Your set-up
1. CIS version, AV database version & configuration used: Version 5.5…1383. Configuration doesn’t matter.
2. a) Have you updated (without uninstall) from CIS 3 or 4: Clean install
b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
3. a) Have you imported a config from a previous version of CIS: No
b) if so, have U tried a standard config (without losing settings - if not please do)?:
4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
5. Defense+, Sandbox, Firewall & AV security levels: D+=Safe , Sandbox=On , Firewall =Sage , AV = Stateful
6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Ultimate x64 SP1, UAC max.
7. Other security and utility software installed: No
8. Virtual machine used (Please do NOT use Virtual box): No

Thank you for your Issue report.

Moved to verified.

Thank you