CIS kills internet


I’m irregularly having problems with CIS. All of a sudden, my Internet access will stop functioning completely.

At first, I couldn’t figure out why, so I had to do complete OS reinstalls to fix the issue, but as it happened again and again, and using a system restore point a couple of times instead of an install, I narrowed it down to CIS. Currently, I’m using version 3.13.121240.574 on Windows XP Pro, SP3 (and all updates/patches), 32-bit version.

The last time it happened, I forced CIS to re-detect my network connection, and it found a “connection #2” and everything worked fine again. [My Network Zones]
It’s just happened again, and it’s getting annoying now.

I searched these forums, and found superficially similar problems, but nothing exact.

Self diagnostics report nothing wrong. If further information is required, please ask.

Welcome to the forum Lone Wolf :slight_smile:

Please try reading this post Reply #7.

It is not unusual for your isp or other servers in the chain you go through to have temporary outages. I have times when I lose connection too but it’s not because of CIS. The other computer here that doesn’t have CIS goes down at the same time every time.

No. Nothing at all works with regards to internet access : Browsers; IMs; program updates; email client; anything. My phone line works during this “outage” so it’s not a cut in the lines.

My ISP is the national provider : British Telecoms. They always email my main account with details of works and outages beforehand. Since 2005, the only time it’s been cut off without being their work department has been when idiots broke into the street grid and stole a connector block. This was repaired within 2 days. I wasn’t using Comodo back then.

To regain internet access with THIS problem, I first completely, after trying for hours to fault-find a setting problem in the OS/Browser/router, reinstalled the OS. It worked (time : ~3 hours with all updates). As I narrowed the problem down the more it occurred, I uninstalled Comodo - internet came back at reboot (time : ~3 minutes). The last time this occurred, I went looking through Comodo control panel, and found an option to detect networks. I clicked that, and it reported it had found a “Connection #2” (There is only one PC, one network, one router - no other devices/consoles). I OK’d that, and internet came back immediately (time : ~15 minutes).

It happened again yesterday, and again, I told CIS to look for my connections, and the Internet access immediately came back. BT service status website has no outage of service reports whatsoever during this time.

So, for whatever reason it is, CIS irregularly “loses” whatever config file it has on my network access connection, and until it’s forced to re-detect, or I disable the program, or I uninstall it, I lose all internet access. Total loss. Nothing gets through. Browsers, programs, anything at all. It’s annoying, now, rather than frustrating, that I know what it is, but not why. Comodo self-diagnostics does not detect any problems while this occurs, only by removing CIS or telling it to detect networks, does the problem resolve itself.

Settings > Miscellaneous > General always has the “automatically detect new private networks” box ticked, yet seems to be irrelevant to this happening.

internet has deserved it ;D

Can you show us a screenshot of the firewall logs of around the time you loose the connection? They can be found under Firewall → Common Tasks → View Firewall events.

I want to see if getting a new IP address is may be causing your problem. What connection are you on; cable of ADSL? Do you have a router in your network?