CIS installation issue

I have McAfee Internet Security 2009 intstalled on a Viista 32-bit laptop. Wanted to install CIS so uninstalled McAfee via Add/Reove programs and then ran McAfee uninstall tool which removes all remaining bits of leftover registry and other components. Then installed CIS. No problems with installation but on rebooting, the computer hangs at Welcome screen. In safe mode, I can see that CIS is installed. Tried unintalling and reinstalling CIS. Bur same problem again. Tried installing just the Firewall but the same problem again. There is no other AV program on the computer and I also turned Windows Firewall off. But still no luck. Any suggestions?

Hi anilparikh, welcome to the forums.

It does rather sound like some sort of driver conflict (the hang at Welcome). Check the Windows Event logs to see what, if anything, was being logged as you tried to start Vista with CIS installed.

Also, what is the actual make and model of the laptop? Some laptops have special drivers that can cause problems in this regard.

Hi Kail,

I will have to reinstall CIS and look at Windows Event log at the weekend. I have the Windows Log service disabled (plus many other services) to save resources. I have a Lenovo Thinkpad T500, with Vista Ultimate, 4 GB memory (only 3 GB usable). Will report back in a few days.


OK, in meantime please read the topic below. Although the topic was last posted to nearly a year ago, it may still have value to this current situation.

hi anilparikh
I thiink you should check the D+ log and firewall log.and I think the rules is error if you set the rules.
you can enter the safe modle to close some unnecessary startup items.then you restart your computer.
if that desn’t still work, you can into other people’s rules in safe modle

Hi Kail,

Some of the posts in the link do suggest that if you have Lenovo Fingerprint reader and Client Security Solution (CSS), especially with embedded chip activated, you MAY have problems. But there are other posts where the forum members have not had any problems.

I have Fingerprint reader disabled and CSS (v8.21) has not been activated. So do you think these installed software could create the hang problem at Welcome screen.


Personally, I would have thought that such a conflict would happen sooner (before the welcome screen). But that is pure speculation on my behalf, as I have no direct experience of this specific problem or the hardware involved. I think the members opinions and views in the topic I cited carry more weight than mine.

That said, objectivity can help and I would still like to see what was recorded in the Windows Event logs. There, as liujianfei says, might be something in the CIS’s Defense+ event log, but since the system hung this unfortunately may not be the case.

Kail- this is what I have done

  1. Uninstalled McAfee Internet Security 2009 and cleaned up remnants with their tool
  2. Installed CIS Firewall only (v3.10 downloaded today - no D+). After installation got an error message stating there was a problem with install and if I wanted CIS to fix it automatically. Clicked OK and problem was apparently resolved.
  3. On rebooting, hung at Welcome Screen again as before
  4. In safe mode, disabled all services except Microsoft and Comodo and only start-up item allowed was Comodo.
  5. Surprise! Rebooted all the way to desktop but hung again at Welcome screen on reboot.
  6. In safe mode uninstalled Firewall and reinstalled also in safe mode after reboot. Msconfig still as in 4.
  7. Still hung at Welcome Screen - attached file: Event Viewer
  8. In safe mode opened Firewall. Error message: Firewall not functioning properly, run diagnostics to fix the problem. Diagnostics did not resolve the issue. Created a log at this stage - file name: Comodo Error Report
  9. Restored laptop prior to McAfee uninstall. All OK now
  10. I also attach another error report from within CIS - file name Comodo Error Report 2. Not sure when this was created.
  11. I incorrectly advised you earlier that I have Lenovo embedded chip as part of Client Security Solution. I do not have it. Both Client Security Solution and Fingerprint reader are disabled.

[attachment deleted by admin]

An additional point in case the following programs could be causing conflicts during installation:

  1. CISCO VPN Cline v5.0.05.0290 - can be removed - no longer in use
  2. Spyware Doctor v6.0
  3. Threatfire - Fully updated - version number not shown
  4. Prevx v3.0.1.62
  5. A-squared Hijack Free v3.1
  6. Japanese Fonts supported for Adobe Reader 8. 0 - saw somewhere in the forum that Chinese fonts were a problem for one members

No response to me post a few days ago. In the meantime, I read on the Forum that another Member had problems rebooting after CIS install and the Moderator suggested solutions for Event ID 7000 and 7026 in Event Viewer. So tried CIS Firewall ONLY install again to get the exact error message.

Had the same procedure and some problems:

  1. Remove every trace of CIS before reinstall and reboot. McAfee Internet Security 2009 already uninstalled previously.

  2. Following Security software disabled:
    a) Spyware Doctor v6.0
    b) Threatfire - Fully updated - version number not shown
    c) Prevx v3.0.1.62
    d) A-squared Hijack Free v3.1

  3. Reinstalled CIS Firewall only

  4. On reboot, system hung at Welcome screen (Screenshot attached - EventViewer1). There are too many drivers not loading but that is not surprising as I had disabled everything except Microsoft Services and all Start-up items in Msconfig. - Critical items CmdGuard, CmdHlp and Inspect are not loading, among many others.

  5. Went into Safe Mode. Strated CIS. Took more than 5 minutes to initialize. gave usual errpr message “Network Firewall is not functioning, please run diagnostics etc”.

  6. Ran Diagnostics. Problem could not be fixed. CIS Diagnostics Report attached. As far as I see, everything looks OK.

  7. Enabled all services and start-up items in Safe Mode and tried booting up. Hung again at Welcome Screen. See screenshot “EventViewer2”. This time only CmdGuard is not loading. CmdHlp and Inspect are not on the list.

Have spent endless hours on this issue. PLEASE HELP!! Previous posts give further details.

[attachment deleted by admin]

Have you been reinstalling the CIS firewall from its original download back on 2 August ?
Or have you tried downloading it again and then reinstalling ?

(sorry… I’m clueless but it’s not clear if you have been reinstalling with fresh copies of the firewall or not)


Fresh copies each time, just in case there was a download issue.

Hi, Some additional testing thanks to helpful guidance on the Forum, I beileve I have narrowed down the cause of the problem. May be someone will post a solution. Here is what I did:

  1. I had manually cleaned up previous CIS Firewall only install but nevertheless decided to be very thorough. Used the CIS Clean-up tool and also CCleaner. In fact there was nothing to clean except one entry in CCleaner registry. Cannot recall what it was. No Comodo in non-plugin devices and Explorer clean of all Folders. Ran Autorun. No trace of Comodo.

  2. Fresh download of the latest CIS today and installed with only Microsoft services running. No start-up items. As before no problems with installation. On rebooting hung at welcome screen.

  3. In Safe Mode, CIS took more than 5 minutes to initialize. Diagnostics showed Defense+ not functioning properly (although it was not installed) and could not be fixed by diagnostics. No entry and Diagnostics log. Ran Autorun in Safe Mode and checked for the following:


  • Comodo Firewall Pro


  • cmdagent C:\program files\comodo\firewall\cmdagent.exe


  • cmdguard c:\windows\system32\cmdguard.sys
  • cmdhlp c:\windows\system32\cmdhlp.sys
  • inspect c:\windows’\system32\inspect.sys


  • c:\windows\system32\guard32.dll

All OK except Last item under AppInit. There was no entry in Safe Mode.

  1. Disabled both the Firewall and Defense+ in Safe Mode and rebooted. Big surprise. Can get to desktop. Changed Firewall and Defense+ settings to Safe and Clean respectively. Ran diagnostics. Everything OK. No problems. Autorun now also shows the AppInit entry, which was missing in Safe Mode. Configuration shows Firewall Active.

  2. Tried to reboot again but hung at Welcome Screen. Checked EventViewer for Event ID 7026 referred to in the Forum. This shows:

a) When system hangs at Welcome screen, the message is: "The following boot-start or system-start drivers failed to load - CmdGuard, tvtumon (A Lenovo driver, which does not load by default and can be ignored per Lenovo)

b) When system boots OK with Firewall disabled, only driver not loading is tvtumon

It appears that with Firewall enabled CmdGuard driver does not load and I cannot boot to desktop. With Firewall disabled, all is well but then I have to reset the firewall and defense+.

Any solutions would be greatly appreciated.

Couple of additional points relating to my previous post:

  1. Although c:\windows\system32\guard32.dll does not show up under AppInit, it is in Windows directory.
  2. Is there a way to modify or create a new registry entry to fix this problem.