CIS install won't complete, keeps "rolling back" near the end

Specs: ThinkPad T40, WinXP Pro SP3, 1.5GHz CPU, 1GB RAM, 160GB HDD (with plenty to spare)

Hi all,

Having a consistent problem when reinstalling CIS on my laptop.

I recently had a problem with an unknown driver causing extremely long boot times. In troubleshooting, I uninstalled Comodo Firewall 3.9 and Avast Home. The driver issue was resolved to a problematic WiFi driver recently installed, so I went ahead and went to reinstall Comodo.

The trouble I’m having is towards the very end of CIS 3.9.95478.509 installation. Everything goes fine through the installation until near the end. I tell the wizard that Yes I’m sure my PC is clean, and all windows disappear for several seconds (like normal) and the installer’s cfpconfg.exe process pegs the processor at 100% as it finishes whatever.

Instead of the installaiton complete message asking for a restart, I get a “rolling back…” message, very quickly followed by a “Rollback done” message a second later. No error messages, no dialog prompts, nothing. Just a nice Finish button to push on the bottom of the wizard window, with no product installed.

What I’ve tried thus far without any luck:

  • Manually removing any file and registry traces of Comodo
  • Running the batch file made by Ragwing to remove any other Comodo traces I may have missed on the hard drive and in the registry
  • Re-downloading the latest installer
  • Installing in Safe Mode
  • Installing as the Administrator user, not just a user in the admin group
  • Installing to a different directory
  • Telling the installer No I’m not sure if my PC is clean and let it do it’s thing (another forum user with a similar problem solved this issue by doing this)

…each time, I get the same exact problem with it “rolling back” the installation, without any errors or anything.

Checking if there was a larger problem, I tried reinstalling Avast and had no problems with that.

Why is the installer rolling back at the very end of installation? Is there an installation log written that I can research? Has anyone else ever experienced this?

Thanks ahead of time everyone.

You have me stumped. I asked the other mods to take a look and share their wisdom here.

Thanks Eric, I’m still stumped myself.

To see if it was a more recent bug, I tried going back to the last Firewall-only version, by my own quick research. This version gives me the same identical “rolling back” issue.

Then I tried version with the same issue.

I should also note that I am also seeing a warning dialog stating:

COMODO Firewall Pro Installer
Problem with deleting the Shortcuts. Please kindly delete the Shortcuts manually.

Behind this dialog (this time anyways) it states “Rolling back 241%…”

After hitting OK for that dialog, the wizard says “Rollback done” and that’s it.

Now here’s the kicker… I just tried installing way back to version and getting the same problem!

Please note that this PC is 100% legitimate and clean, I am an IT tech. Malware is out of the question.

Is there any location I could find an installation log?

Thanks guys.

Maybe there is something recorded in %temp% ? or in the windows event log ?

I have seen similar situations to this in the past. Not with CIS, but the problem is the same. Sad to say, I never actually found the cause. Only a complete reinstall fixed the problem.

That said, I have a feeling it’s a registry related issue; Perhaps a malformed key that a particular installation needs. How to track it, however, is another question.

If you have the time, you could try running sysinternals filemon and regmon during installation. Maybe the data will provide some clues…

Sorry I can’t be more helpful.

@Toggie: Yeah one of the things I’ve also tried was Process Monitor. There was a LOT to sift through, but I didn’t find anything particularly abnormal. Perhaps a developer would know what to look for.

@Ronny: One of the things I was looking for in Procmon was a log of sort being written to a temporary directory or something, but nothing turned up.

Also, the MS Windows Installer Cleanup utility doesn’t show anything Comodo, as I imagine it wouldn’t since it is not an MSI package.

I’ve included a screenshot of what I’ve described in case it rings any bells.

[attachment deleted by admin]

Can you try to install Comodo Vulnerability Analyzer ? see if that installer finishes ?

I think the delete shortcut errors are from the current rollback, not way it rolled back, just locked by the installer.

Can you post any other security software installed on the system, no matter if it’s on-demand or not, and did you “tweak” anything on your OS settings ?

@Ronny: Just tried installing the Comodo Vulnerability Analyzer and that didn’t finish either, same rollback issue.

The only security software installed is the latest version of Avast Home. However, I tried installing Comodo both before and after I put Avast back on and had the same problem. I’ve had ThreatFire installed before this rollback issue ever happened, but left that out since it would only complicate things. As far as on-demand security software goes are portable security apps such as Kaspersky Virus Removal Tool which I run every so often and ESET SysInspector.

There have been no questionable tweaks applied to this system, such as bogus registry performance claims or the like.

I’ve tried installing other software without any issue.

There were a few event log application errors that didn’t list Comodo and didn’t appear during Comodo installation’s time frame, but they were related to .NET v3. I ran a repair with .NET 3.5 SP1 and it didn’t solve the issue at hand.

So it’s something “general” with the Comodo Installers not CIS Specific…
Can you see where the installer is at the point it starts rollback probably in registry ?
Maybe compare that to the point where CVA is at rollback ?

Maybe it starts the rollback because it can’t write to a specific key in registry ?

A user here bails out the install here:;msg281224#msg281224

He restarts his system at this point, and was able to install, he’s only missing the shortcuts…

I was just about to reply that I just tried that.

Haven’t read the post you referenced, but I terminated the installer’s processes when the “is your PC clean” dialog came up. After a reboot, everything checks out fine, including a Diagnostics run from within Comodo.

Process Monitor shows a log of registry entries being written to HKLM\System\Software\Comodo after that point in the installer, so I’m not sure how much I’m missing here.

I’ll post my results about this dirty install in the future to make sure everything is working out okay. It’s too bad we couldn’t get to the root of the problem though, but if anyone has suggestions I’d gladly try and work this out for future reference.

Thanks guys!

Normally it would run a runonce key:
C:\Program Files\COMODO\COMODO Internet Security\cfpconfg.exe -z -o
Maybe you can run this manually this will create some stuff under the mentioned key, not sure if it will write all but i don’t think it will hurt running this now again.

What i am wondering now is are you able to do a install of CVA without problems now ?

I’ve just tried installing CVA before and after running that command manually, and both times got the same rollback issue.

cpfconfg.exe was active for maybe a second in Process Explorer and closed. If it’s just writing to some keys, I suppose that’s about right.

I’m contemplating running an MS tool to rewrite the permissions of all the registry keys and checking if that solves the problem.

EDIT: The command from was applied and did not fix the problem. It ran through fine, however Avast protected some of it’s own keys from modification.

My HKLM\System\Software key has Everyone Full Control permissions.

Same permissions here, for the Administrators group at least.

Leaving CIS alone for now, I’ve just run a trace on CVA_Setup_1.1.5.52_XP_Vista_x32_BETA.exe for any clues. Since there is no pause in the installation between when the files are copied to disk and when it rolls back, it’s difficult to pinpoint in the trace any single point of error.

If you have any suggestions for what in the trace I may want to search for, let me know.

Maybe reduce the procmon output to only registry could help ?

One other thing a developer posted that just before the error you receive for the “shortcuts” you should be seeing an other “error message” that should point to the cause of this, is there any chance you can capture that ? maybe by running CamStudio on the installer to create a video of the install failure…

I just ran it through CamStudio and checked it frame for frame, never got an error message at all.

Just to clarify, I’ll give a play by play:

  1. Hit Next button for “Choose Destination Folder”
  2. Extracting files…
  3. Installing files…
  4. Wizard window closes/hidden
  5. Wizard window returns, Creating shortcuts…
  6. Rolling back xx%…
  7. Problem with deleting the Shortcuts. Please kindly delete the Shortcuts manually. (Identical to screenshot posted in earlier post)
  8. OK button pressed
  9. Rollback done.

I can send you the AVI if you like, but I’ve scanned every frame. Perhaps CamStudio isn’t capturing it quickly enough, I’ll run it a few more times.