CIS GUI and Log Viewer hangs when try to load icons from offline UNC paths[NBZ]

The bug/issue

  1. What you did:
    Click on View Defense+ Events

  2. What actually happened or you actually saw:
    Comodo GUI freezing (white background, waiting to respond message). After a long time (about a minute) The window opened.
    Same problem happens with the Log Viewer once you scroll to the entry.

  3. What you expected to happen or see:
    Log Window opening.

  4. How you tried to fix it & what happened:
    deleting all logs with log viewer helps.

  5. If its an application compatibility problem have you tried the application fixes here?: no

  6. Details & exact version of any application (execpt CIS) involved with download link: none

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    steps to reproduce:
    open an unknown program from an UNC path: \computer\share\some.exe
    a CIS alert will appear
    Answer the alert.
    Disconnect \computer from the network.
    (could be necessary: reboot to clear icon cache)
    Open the Comodo Log viewer or click on View Defense+ Events
    The GUI will hang.

  8. Any other information (eg your guess regarding the cause, with reasons):
    This is probably caused by CIS trying to fetch the program’s icon. It should be fixable by using a new thread to get the icon in background, so that the GUI will not be blocked.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: yes
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: no
  3. A CIS config report or file: no
  4. Crash or freeze dump file: no

Your set-up

  1. CIS version, AV database version & configuration used: 5.3.176757.1236, 7809
  2. a) Have you updated (without uninstall) from CIS 3 or 4: no
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+=safe , Sandbox=off , Firewall = custom policy, AV = on
  6. OS version, service pack, number of bits, UAC setting, & account type: Win7 RTM x64 UAC on, Admin
  7. Other security and utility software installed: no
  8. Virtual machine used (Please do NOT use Virtual box): no

EDIT: More info on OS & User (although I don’t believe it’s relevant)

[attachment deleted by admin]

Could you please post the missing information in your first post.

  1. OS version, service pack, number of bits, UAC setting, & account type: Win7 x64 UAC on

Thank you



Thank you for your bug report in the required format.

Moved to verified.

Thank you