CIS free version insisting I buy Activation code!? WHY?!

I recently formatted my SSD & reinstalled CIS after Windows, & earlier it said I had to activate it, or it wouldn’t work in 10 days! I have never gotten said msg before, & it’s the FREE VERSION! I uninstalled & re-DL’d & reinstalled, & the same ■■■■ is happening! Please explain this to me! Also, after fresh install, the updater keeps having errors on DL’ing Website Database Updates. It just says unspecified error! & in the settings under Updates, everytime I try & checkmark the box for “Use Full Signature Database”, I get a msg saying that I must have administrator rights in order to do this! & says, do you want to restart advanced settings w/elevated privileges? & I click “YES”, the window refresh & the box is unchecked! & this just keeps going in circles endlessly w/out it actually keeping the ■■■■ box checked! & I AM the administrator! WTF?! Please help! BTW, I’d have screenshot these msgs & sent them through here, but, there is no option to do so!

Probably a year or so ago now, not long after Xcitium, the website only shows the Pro Version of CIS to download. To download the free version, you need to download the Premium Version which is the Free version from the forum. See below links.

Download CIS Premium:

CIS .8012 Premium: Download

CFW .8012 Stanalone Installer: Download

CIS Beta2 Version: Download

CIS Beta topic: CIS Beta2 - 2024 topic

CIS Uninstaller Tool: [Download] - Only if there’s an issue with the program not uninstalling properly:

There have been some intermittent website database download issues but it’s something they have been working on when there’s been an issue. Might be worth posting the issue in this related topic.

1 Like

Hi dude, thanks. :metal:

Which version should I DL though? :thinking: The standalone, or the one listed above that? :thinking: & WHY did Comodo do this w/the main DL page for this prog? :thinking: :face_with_raised_eyebrow:

The Standalone is just for the Firewall if your only using CF but you can still use the Premium and deselect the components you don’t want in the installer options.

Don’t forget to click on the Options in either Installer for 8012 as those installers still came with Comodo Dragon, Internet Security Essentials etc. The Beta Installer doesn’t include installers for the additional software.

I think it was more about promoting the Paid product at the time and the website is less of a priority than the Xcitium one which is for their Enterprise customers. The Pro version did use to give you the option to revert to the Premium version after the trial expired but I, like you, had troubles with it.

1 Like

Thanks, I used the one you suggested above. & all is well, except for the fact that is still telling me I need to have Admin privs to use the “Use Full Signature Database”, in order to actually use it, & it keeps going in circle jerks of saying click yes, & when I do, nothing changes, & it won’t actually allow me to check that box! WHY is this happening?! It never did before yesterday! :thinking: :face_with_raised_eyebrow: :roll_eyes: :unamused:

1 Like

I’ve not had that issue previously, strange. I’m just using the Firewall at the moment. The full database isn’t needed really and CIS always checks cloud signatures as well as local ones and anything unknown gets put into Containment and therefore not do any damage to your system. Think of signatures as labelling a malware in terns of CIS with Containment.

Anyway, can you provide version number, operating system and a screenshot of possible so that @ilgaz @C.O.M.O.D.O_RT can you assist.

1 Like

Thanks. It should still work & not tel, me this ■■■■. & I even tried running it as admin, by right clicking on it & choosing that option, still the same ■■■■! & It is version: How do I upload screenshots to here? :thinking: :face_with_raised_eyebrow: & I am running Win Pro 8.1 64 bit.

You can use the Upload button:
or just do an Alt + PrtSc and paste it in the message.

I found this topic which I’ve pasted below advising what to do: Post

If you are looking for help regarding “Use the complete signature database” feature. Here I can explain you how it works.

By default CIS uses Light Signature DB, but customers can switch to Complete signature DB at any time. In both cases its better to have cloud scan enabled. However, Complete signature DB uses less FLS requests and is much more preferable for offline scan.

Switching to Complete signature database:

  1. Go to Advanced Settings → Updates → check “Use full signature database”.
  2. Select “Yes” on CIS popup to have administrator rights to switch database.
  3. Advance Settings page will be restarted. Now check “Use full signature database” again.
  4. Select “Yes” on CIS popup to download full database.

The help documents will be updated soon with the detailed explanation of this feature.

1 Like

I didn’t even notice that upload button before, my apologies. At any rate, I did exactly as you describe above, but it never “takes”, it keeps saying the same ■■■■ over & over again about needing to have admin privs! Complete circle jerks w/this prog! No clue how to fix it either! :roll_eyes: :unamused: :confused: :neutral_face:

It may be how Win 8.1 deals with admin rights and beyond my scope of knowledge. We’ll lsee what @ilgaz and @C.O.M.O.D.O_RT respond with.

1 Like

Ok, but, how come I never encountered this prob before though? & I’ve been using 8.1 since 2016. :thinking:

I’m not sure. It is odd. I was thinking that maybe CIS isn’t loading with Administrative Privileges so I had a thought, if you go to the CIS folder in Program Files and then Right click on CIS.exe and then select properties and then “Run as Administrator” in the Compatibility tab like below:

Did you update Win 8.1 recently? It might be the cause of a recent Windows Update?

1 Like

That fixed it! Thanks!

SMDH! I NEVER had to do this w/any other version of CIS EVER! :face_with_raised_eyebrow: & I’ve been using it since about 2009, 2010. :thinking: :face_with_raised_eyebrow: :unamused: Maybe it was even earlier than that. Maybe '07 or '08. :thinking:

1 Like

No, only all the updates after my recent format of my SSD.

For your information, CIS versions after will no longer install / work on Windows 7, 8 and 8.1.
Windows 10 or 11 are required for running latest CIS (Beta) versions…

Well, I’ll just keep on using the one the dude above gave me the link for, which I already DL’d then. I am building a new system soon, & will unfortunately have to run W10 on it, so, i won’t have to worry about it after that.