CIS Free on Windows 8.1 not working

Dear Sir/Madam,

I have used Comodo Internet Security Pro Free, it have been working correctly until i have upgraded my pc yesterday from Windows 8.0 Pro to Windows 8.1 Pro.

The program Comodo doesn’t start anymore. Can you tell me how i can solve this problem ? i can’t uninstall Comodo.

I hope theire is a tool so i can repair the installation and solve the Comodo problem. At this moment i have no good anti-virus and firewall, because Comodo fails to start.

When theire is a new version of Comodo which works correctly with Windows 8.1, i hope someone can send me a message/e-mail, so i don’t have to check multiple times a day this website for updates.



Hi, adriaan6.

If you want to uninstall CIS, these tools may be made some help. PLEASE follow the instruction correspondly.


  2. Revo Uninstaller: Uninstall Software, Remove programs easily - Revo Uninstaller Pro

  3. Total Uninstall:

Good luck.

I’ve been seeing reports of this issue lately. It seems that something about the upgrade to 8.1 corrupts something with CIS. To reinstall please follow the advice I give in this post. This has been able to solve the issue for most users.

Let me know if it fixes it for you.


I had to reinstall CIS as well. It wouldn’t load completely.

Hello guys, Windows 8.1 update destroys CIS registry data.

You can return CIS into working state running the diagnostic manually:
please run following command in CIS working dir, typically “C:\Program Files\COMODO\COMODO Internet Security”:
cis.exe --diagnoseUI

It will restore CIS functionality but windows upgrade destroys your settings.

I can’t solve this problem.

I have now updated Windows 8 to Windows 8.1 on three computers which had the most recent version of Comodo Firewall 6.3 installed.

On the first computer, I did not uninstall Comodo Firewall before upgrading. After upgrading, Comodo Firewall did not load completely, I had to uninstall it, then run the CIS Removal Tool 2013 from, and install again.

On the second computer, I uninstalled Comodo Firewall before upgrading, then ran the CIS Removal Tool 2013, upgraded, installed Comodo Firewall again and restored the settings I had exported. No problems whatsover.

On the third computer, I uninstalled Comodo Firewall before upgrading, but did not run the CIS Removal Tool 2013, upgraded and tried to install Comodo Firewall again. Although the installation appeared to proceed normally, the computer was not able to re-boot into Windows and I had to boot in safe mode and run the CIS Removal Tool 2013. This managed to remove everything that had to be removed, and I was able to install Comodo Firewall normally.

So, in my experience, uninstalling Comodo and running the CIS Removal Tool 2013 is essential. Just uninstalling is clearly not enough.

I did it without using the removal tool. First I used CCleaner to uninstall CIS. Then I ran the CCleaner registry clean, followed by a run of Auslogics Registry Cleaner and a reboot. I then reinstalled CIS and it worked. Of course I had to download the AV database and do the quick scan over again. Then I had to reapply all my CIS settings that I use. After all that, it’s back to normal.

It wasn’t just CIS either that got broken. I also had to reinstall my video driver and Classic Shell.

Somewhat off the topic, I had to run a boot defrag with Puran because my registry was in 45 pieces after the 8.1 upgrade and the drive was heavily fragmented with empty spaces everywhere. I also had to remove the 6GB windows.old folder to regain the space.

I more or less had to do the same as you Dch48, and thanks for the heads up on deleting the Windows old folder. Just got finished setting up Comodo CIS and all is well again.

I also had problem with CIS 6 Free after upgrading to Windows 8.1 Pro 64bit. It would not start at all. I even tried clicking on the icon. I removed it using Advance Uninstaller and reinstalled it and now it is working fine.

I did have an oddball problem downloading CIS. The link took me to and I downloaded the file. When I click to run it, I got an error message about 7zip archive. I don’t remember the exact message. I downloaded it again and got the same error message. I tried running it as administrator. I found another link in forum message that downloaded it and this time the program worked.

I checked the download history and the first 2 downloads that had the error message came from and the last one that worked came from I thought this was interesting. Users may want to mane sure that the download is from comodo. There seems to be a problem with the version on cnet.

Hello everyone,

I also had the same problems. My solution that works perfectly for me:

  1. uninstall Comodo firewall with “Revo Uninstaller”
  2. launch (in administrator mode) File “CIS+Removal+Tool+2013.bat”
  3. reboot
  4. install Windows update (8 to 8.1)
  5. reboot
  6. installing Comodo Firewall 6.3

Everything works for me. Windows 8.1 x64

Sorry for my bad english :cry:

Hi guys,

We released new CIS update that is solution for the users who doubt upgrade Windows 8.0

Now CIS processes specificity of the upgrade in a proper way and as a result CIS restores all user’s settings after the upgrade.

Using 8.1
I did all the above and quite frankly all failed being on a 64 bit no revo, the bat file did nothing, used IO instead, failed, but I did fix it myself.
MY steps: Which may be of help or not?
Uninstall, obviously
go to the net work adapter setting make a note of whats there QoS, printer sharing etc.
Uninstall everything but the IP4 and IP6
Make sure your net is still working OK.
Install CIS in ADMINISTRATOR MODE something which I forget earlier and follow prompts etc.
After restart if it comes up and it’s not in the task bar don’t click on the comodo icon, click on the shared files instead. Wait a few and it should pop up in the widgets should be a yellow FIX ME indicating restart.
Should work now.
I might add it’s shoddy programming you guys have know about windows 8.1 for quite a few months now and we’re still getting this problem which is remarkable easy to fix on my own but somehow you guys can’t fix it in a new release and also remarkably prevalent judging by the amount of posts.
I mean how long do you guys need to fix things for 8.1release when you knew it was around months back and a major upgrade for windows??
Anyway worked for me after all else failed. Might be of help to someone.