CIS firewall stall upload speed at 0.113Mb/s


I have windows 7 - 64 bits and use Avast free AV. When I install Comodo firewall (and only the firewall), my upload speed fall at around 0.113Mb/s??? The only way to get back my 7Mb/s upload speed is by removing Comodo firewall and repairing my internet connection…

What could be the problem in Comodo firewall that could explain that my upload speed get to a crawl with Comodo firewall aboard???


I Run Avast 8 Free antivirus and free Comodo firewall.
When installing avast i unchecked the behavior shield and disabled the avast auto sandbox as well.
I have no issues with Comodo and avast and uploading files at all.

Windows 8 x64

You could try disabling the comodo firewall driver on your adapter to see what that does.

but i have a Western Digital Nas…And when copying files to it i get around 30 mbits…

What happens if you disable all shields for Avast?

I also have uploaded large files to my free Comodo Cloud account.
I have 5 mbits up…but the best i can do on Comodo cloud is around 750k second.
but i have hit faster speeds on other sites uploading…

My upload speed still at 0.113Mb/s… I also tried disabling comodo firewall and the problem persist! The ONLY solution I found is by uninstalling Comodo firewall!

I always disable all the shields of avast when installing Comodo firewall…

Well what i am really saying is the Avast Behavior Shield and it’s AutoSand Boxing conflict with comodo’s Behavior blocking and auto sandboxing. So you must choose one or another.You can’t run both…
Or you will have some strange behavior…

@ atomas31, what happens if you disable all components of Comodo Firewall, including the Behavioral Blocker?

Out of curiosity, are you talking about general uploads or is this when using a p2p application?

I was using only the firewall, the BB was disabled.

I am not talking about P2P application but the usage of Internet and also try different speed test with all the same results… localhost
::1 localhost

do you have these defined in c:\windows\system32\etc\drivers\hosts file?
by default Microsoft disables these definitions with a # infront of them like this. which tells windows to ignore these entries.

# localhost
#::1 localhost

the top is ipv4 and the bottom is ipv6

may help…
after changing the values in the host file. disable the Ethernet and re-able the ethernet.