CIS Firewall not showing prompts for new connections with "Custom Ruleset"

I installed CIS yesterday, for the first time in over 2 years. After the initial setup, and reboot, I placed the firewall into training mode, restarted my computer, and used it for a bit that way. Before I was done, I set it to Custom Ruleset, and got one prompt right after changing it, but have not gotten anymore, and new applications are just being blocked.

At this point, unless the firewall is set to training mode, I have to go into settings, and manually allow network access for each new application, the hard way. (Been using training mode instead, and running only apps I trust)

I really wanted this only for the firewall, but was forced to install the other components to get the firewall. I originally removed this a few years ago, because I had nothing but problems with it, and already I’m having problems with it the day after install.

Here are the relevant settings.

OS: Win10 Pro 21H2
Firewall settings:
Enable firewall: Enabled with Custom Ruleset
Do not show popup alerts: unchecked
Enable trustconnect alerts: Unsecured wireless networks only
Turn traffic animations on: checked
Create rues for safe applications: checked
Set alert level frequency: high
Set new onscreen timeout to: 120 (checked)
filter IPv6 traffic: unchecked
filter loopback traffic: checked
block fragmented IP traffic
Do protocol anaylsis: unchecked
enable anti-ARP spoofing: unchecked

File Rating Settings:
the only enabled option is to detect PUPs

(tested with file rating settings at their defaults too. same issue)

If there are other settings to take into consideration, please let me know. Any help would be greatly appreciated. Thanks in advance.

Edit: Found a link to install only the firewall. Uninstalling CIS, installing only the firewall, and adjusting settings to match what I had when the problem started resolved the problem. Guess the install was bugged.

Are you running default configuration or Proactive? Try running Stealth Ports under Firewall tasks and select Block Incoming as the later will alert you for new connections.

Most people use Safe Mode for firewall but check the logs to see what’s being blocked.