CIS Firewall not remembering application rules


I’m using CIS, it’s freshly installed. The Firewall is not remembering application rules and keeps prompting me each time I start an application I don’t want accessing the Internet, remember my answer is checked.

I have tried creating a blocked application via Firewall Tasks>Block Application then specifying the EXE yet it still prompts me for that App.

Any ideas?


At first go to the advanced settings / firewall settings / applications rules From then choose a new rule and choose “use a custums rule” then choose option “copy from” and choose allowed app

If this does not work the way Try re-install Comodo If you also did not succeed after the re-installation may be bugs

Sorry for my poor English

Hello SD Ahmad, thanks for your reply. I want to block the application not allow it.

P.s. Your English is fine! :smiley:

iam sorry for miss

Please 'You choose the option to blocked applications Instead of allowed applications option

That is what I have done. Any help from a Comodo rep would be nice!