CIS Firewall Broken/No connections

A. CIS Firewall Broken/No connections
Can you reproduce the problem & if so how reliably?:
no. Seems to happen after a few days
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Install/Upgrade CIS Premium
3:Firewall no longer works. Also new version 12.1 can’t install Killswitch(access denied error)
One or two sentences explaining what actually happened:
Noticed that some apps i block were going to the internet. checked CIS main panel
and noticed there were no connections in the firewall section of the main tab.
Tried to install killswitch and got access denied error when it was trying to install.

One or two sentences explaining what you expected to happen:
Expected the firewall to block applications with a rule to block them
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
not really. blocked powerdirector 17(PDR.exe) from internet and software_reporter_tool.exe from running
Any other information, eg your guess at the cause, how you tried to fix it etc:
just happened randomly afaik, upgraded from to to try and fix it.

Exact CIS version & configuration:
CIS Premium 31782
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus: Stateful
Auto-Containment: Enabled
HIPS: Disabled
VirusScope: Enabled
Website Filtering: Enabled
Have you made any other changes to the default config? (egs here.):
no. Blocked an app in the firewall(PDR.exe). Blocked an app in containment(software_reporter_tool.exe).
Have you updated (without uninstall) from CIS 5, 6 or 7?:
no. upgraded from to
if so, have you tried a a a clean reinstall - if not please do?:
no. did a normal reinstall which fixed temporarily
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
yes? upgrade remade config
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Microsoft Windows 10 Home, Version 10.0.18362 Build 18362, 64 Bit, default UAC, normal account, no VM used

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
no (norton antiviruswas included with laptop. but is now uninstalled)

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Had to delete *.dmp from the to meet minimum file size. each one is
~300MB. I tried uploading this and it reset my whole post :(. Tried previewing and it reset my whole post. luckily i had it copied

You should try with the new beta which has several fixes, make sure to uninstall using the official uninstaller tool to properly uninstall CIS as 12.1 has a bug in which CIS fails to be properly uninstalled.

Could not run the installer.

Steps Completed:
1: Run linked ciscleanuptool_x64.exe several times. Rebooted many times.
2: Run local uninstaller for ISE, Secure shopping, and dragon (as they were not removed and i noticed the icon for SS)
3: Run linked cispremium_installer.exe for CIS This produced a 404 error. assuming some web file is missing.
4: Modified post to add an image that shows the exact error.

You need to read the post on how to install the beta, you have to modify the host file to download from the beta server.

Hi grimrah,

Thank you for your great effort and reporting.
Could you please check your inbox for PM and provide us the log for investigating this issue.

This is an known issue and it’s fixed in the latest v12.2.0.6938 Beta 1 version,it will be reflected in the upcoming stable release.

Kindly add in host entries: C:\Windows\System32\drivers\etc\hosts

Thanks in advance!


Got installed and it is currently working correctly.
Though it was working for a while before when reinstalled.

Sent Dharshu many a log file via PM.

Hi grimrah,

Thank you for your Co-operation.
In future if you are having any trouble regarding this kind of issue please feel free to inform us.