CIS Firewall blocking android SDK

I have a problem with the firewall.
Installed Android SDK, but it would not communicate with Eclipse.
After a lot of troubleshooting, I realised that the firewall was blocking it.
when I disabled the firewall, the SDK had no problem communicating with Eclipse at all.
I had set up the related applications as Trusted applications but it would not work at all.
now every time I need to work with the SDK, I need to turn off the firewall.

Can anyone offer advice on how to configure the firewall for the SDK to work properly ?
I know the SDK communicates thru port 5554 on localhost.

Thanks a lot !

Can you tell us more about how this works?

What is Eclipse? Where is Eclipse running? What is the version number of CIS? Is it a clean install or an upgrade install?

I come from taiwan, and I have the same question, too.
Eclipse is a integrated development environment (IDE) which develop java applications, and it can develop android applications through
the Eclipse plugins.

here is the android installing manual (english)

android installing manual (chinese)

Eclipse plugins will communicate android emulator (emulator.exe) and android services (adb.exe)
I just close the comodo firewall and solve the problem.

OS: Windows 7 x64
Eclipse x64
android sdk x32
jdk x64
comodo firewall 5.3.176757.1236

Can you show the Defense + logs of around the time you are working? They are under Defense + → View Defense + Events.

I think this problem is related to problems I have seen reported when using Visual Studio application. Read How to use Visual Studio debugger with CIS [v5] for reference. There may be helpful clues in this FAQ topic.

Also try a search query with Advanced Search with search term Visual Studio over the last 300 days. That could bring some more insights.

What I recall from this type of topics is to give the debugging program the Installer/Updater policy, use a dedicated folder specifically for temp files the debugger produces and add that folder a Trusted Applications…

did you mean this log? (see the attachment)

By the way, the emulator was not working since I posted, no mater what I turn off and on the comodo’s firewall.
Seems that the Sandbox features can’t turn it off, huh?
Defense+ has too annoy message and poor compatibility, I just want to use the friendly firewall.

Here’s another bug.
When you started Windows XP, with in the welcome screen. Comodo’s firewall gui interface will crash through the “Remote Desktop Connection” login.but the firewall is still running in the background.

I’m sorry for my poor english.

[attachment deleted by admin]

I remove the firewall and everything going be ok.
here is the complete trace log, grabbed by process montier

and Eclipse normal deploy log. It showed the following text

New emulator found: emulator-5554
HOME is up on device ‘emulator-5554’

are right.

thank for your help

[attachment deleted by admin]

I can report the same exact problem. Note: Disabling the firewall doesn’t help, only complete uninstall really works. To learn more about the ordeal I went through on the way to having a working integrated Android development environment on Windows 7 64-bit work, read the following thread:

BTW, I would have used the venerable Sygate Personal Firewall (just as I do on XP) but unfortunately it is not supported by Windows 7.

If you guys are all using Android 2.3, perhaps that is something to consider as the problem. I can;t really offer valuable information here other then say I have set up Eclipse and the Android SDK on my PC before, and had absolutely no trouble getting the two to communicate. I did not have to do go out of my way to configure anything. Any configuration I did was simply through automated pop ups requesting permission. Nothing more.

Was this ever resolved? I’m having the same problem now, using eclipse fresh install with the adk, if I uninstall comodo it will allows the emulator to run but the firewall will block no matter what settings I choose even if I turn the firewall off temporarily. I would like to continue using comodo but I need to develop as well, is there a fix for this somewhere?

I’ve literally gone through and created custom rules for every single executable in the eclipse, java, and adk folders I could find, including all of the batch files as well, nothing works, its just blocking the emulator from installing the apk files which basically makes it impossible to test my project.

I would think this would be of some concern as to the integrity of the comodo firewall correct?

I had the same problem.

Android 4.0.3, WinXP, Eclipse 3.7.2, CIS 4.1

Trying to run the application in the emulator, I could see the emulator-arm.exe running in task manager, then disappear.

I went into Comodo - Defense+ - Common Tasks - My Own Safe Files window and added the whole
‘tools’ folder, where the emulators live, (including sub directories) and the ‘platform-tools’ folder - where adb.exe lives, (including sub directories) from the android-sdk path. Then the emulator would run from Eclipse. Probably only need to add single files to the safe list, but I haven’t tried it yet.
Hope this helps.