CIS + Firefox [Solved]

Hi guys,

This is my problem. I switched from CFP to CIS_Setup_3.5.55810.432_XP_Vista_x32.exe this evening. Configured it exactly the same way as with CFP. Choosed the best firewall protection.

-Custom policy, alert frequency very high, defence plus in safe mode. Now when I start Firefox and try to surf CIS is bombing me with alerts on each and every site. Even when I want to access it alerts me at least 3 times. Even when I downgraded the alerts settings the issue iwas still there. Before it seemed that CFP was capable to alert about dangerous incoming connections and secure connections only.

Or maybe the issue can be solved in Firefox settings? As I downgraded back to CFP_Setup_3.0.25.378_XP_Vista_x32.exe and I am still bombed untill I set Firefox as a completely trusted application. Then I don’t get any alerts at all.

How to solve this? Maybe it’s Firefox related?

Please, can anybody help me?

I tried a previous versions of Firefox. It definitely is not Firefox related. As I said before, it was possible to have Comodo alerting me about insecure stuff in FF only. Now it alerts just about everything. Even if the settings are not on the highest level. Crazy.

If Possible, Have you tried to remove CIS and then reinstall CIS ?

Once Alerted, Did you select “Treat As : Web Broswer”?
and made sure that “Remember” Box was checked?
What other security applications are you using and what operating system are you using?


Yup, tried to uninstal and reinstall several times.

Using XP SP3 Pro. Installed 1 hour ago.

CIS is the only security application I have at the moment.

If I set it to treat as web browser I don’t get any alerts anymore. However, it was possible before to avoid treating it as web browser and allowing every connection manually. Still, it didn’t bomb me with so many alerts. It was only alerting me about some unknown incoming connections as well as secure connections.

I don’t understand why this suddenly changed and who’s fault is it. As I have installed XP tonight and couldn’t get any viruses as I didn’t surf anywhere.

a web browser like FF has to be treated as a web browser… i can’t see the trouble about it… :THNK

cvsa is right, treating as Web Browser can remove most part of alerts(or even all if your browser makes only safe connections)

The reason of such big amount of alerts seems to be in alert frequency level settings. Very high level would alert you for every host and since most sites content is distributed (banners, images, e.t.c) you can get tens of alerts opening one web page.

You can just lower alert frequency, but the best way to solve the problem it to treat FireFox as Web Browser

I see, and it should be safe to treat it that way? Ok. Well, as I said, it was possible to allow every connection manually before (with the alert settings set to the highest level).

Ok then, if it’s safe to treat it that way, I’ll do it. I thought that would be dangerous. But I am not a computer expert. :THNK

Treating as Web Rowser is not the same as allowing every connection. It just allowing connections usual for web surfing. But if your Browser would do(or some malware make it do) any unusual, harmfull action - you’ll be alerted anyway.

Ok. Really good to know. As I can be paranoid. I am not a big noob but didn’t know this.

Thanks for clearing the things Dchernyakov and Cvsa. (:WAV)

By the way, I changed the topic name as it wasn’t really true. (:TNG)

Thanks again.

  • Thread Will Be Closed -
    Reason: Issue Solved
    To Unlock: PM A Moderator