CIS does not register in windows security on Windows 32-bit

There is a problem with 32bit windows 10 1903/1909 integration. it does not register in windows security at all.

Tried on clean install of win 10 1903 and then on 1909. Does not register in windows security.

Maybe it’s the same as my problem, but mine is 32 bit.
Read the posts below:

For the moment I am still using the 6882, waiting for the update to Windows 10 2004.

I found that 6882 is working fine under win10 32. but 7036 does not work at all with integration into windows security

Hello ghostza,

Thank you for reporting.Did you got any error message/ Any pop-up message?Please share us.
Have a nice day!

Kind Regards,

No I had no pop-up or error message from comodo , just windows security that showed defender running and firewall. I normally disable windows firewall and in doing so realized that windows does not see comodo as installed . Tried resetting windows security center and that did not fix it. Used cis uninstall tool to remove and was amazed that after the second reboot (CIS should be missing) the pc looked as if comodo has just been installed . Asking for DB update and scan again , but still not registered. Had to run the uninstall tool again to get it removed completely. This was strange but happened. After the second run installed 6682 and it worked first time. In-place update broke it all again and had to use the uninstall tool again to get back to 6682.

Hope we can get this solved

I’ve got no problems with win 10 64bit as I’ve got six Pc’s running happily on it , just 32bit that is a problem


Hello ghostza,

Thank you for your response and we are checking in it.
Have a nice day!

Kind Regards,

V12.2.2.7036 (Firewall only) on Windows 7 Ultimate 64-bit

After logging into Windows 7 I’ve noticed (till now) two times that Windows reports a message in the Action Center (in the Flag tray icon) about “Turning On a Firewall”.
The CIS tray icon is visible when the Action Center message appears however, when this situation happens I noticed that the CIS tray icon appeared rather quickly when the desktop appeared after logging in. Normally the CIS tray icon takes quite a long time before it appears (maybe up to 1 or 2 minutes) and it is usually the last icon that appears in the tray.
When I do not take action to the message in the Action Center and I just reboot Windows 7 then everything returns to normal (no Action Center message and CIS tray icon taking a long time to appear).
Now all this happens very rarely, I’ve noticed it happen only two times till now.

When it did occur the second time I opened up Action Center and took a screenshot after selecting “Turn On COMODO Firewall”.
I was presented with two options as can be seen in the lower window in the screenshot.
I did not select any of these options and selected Cancel instead and rebooted Windows 7 which returned everything to normal.

Seems to me that there is some glitch in starting up the Firewall and for Windows to recognize it.

Check what CIS is reporting about its state. That is leading. When CIS is reporting it is running without problems then everything is hunky dory.

The Windows Security Center is nothing but a dashboard that reports what a security program reports about its state. However the registration with Security Center is flaky in general. It will not always properly or timely register the state reported by security programs; this problem happens with a slew of security programs. That’s why we advice to look what CIS reports about its state because that is what WSC should reflect.

You should only worry when CIS reports its self something is wrong. When WSC reports a problem and CIS does not report then WSC is not properly in contact with CIS (then it is a (temporary) glitch of WSC).

Thank you for your clear explanation, I appreciate it.

Indeed I didn’t check if CIS had a green status bar telling “All systems are active and running”. I will check the status bar when it happens again but I think everything will be fine and nothing to worry about.

What I did like about it though, was that Windows 7 started really quickly, there was no delay of 1 to 2 minutes waiting for the CIS tray icon to appear (in the meantime you almost can’t start anything so you have to wait for CIS to finish).
It would be nice if that “quick startup” feature could be implemented somehow. :slight_smile:

Too bad I was hoping for another version completely compatible with Windows 10 32 Bit …
the 6882 remains the only one without any problem.
However, I look forward to Darshu’s analysis.

And let’s not forget the users who are running Windows 7 32-bit …


Sure,I’m working on the reported issue.Let me notify you once completed.
Have a nice day.

Can those who have this issue run the following powershell commands and provide the output?

Get-WmiObject -Namespace root\SecurityCenter2 -Class AntiVirusProduct
Get-WmiObject -Namespace root\SecurityCenter2 -Class FirewallProduct

Please check with