CIS does not like GSAK


Not really sure where to post it, but I’ll start here.

I have the latest CIS installed, but I have a problem with one program that does not work now. It’s called GSAK (Geocaching Swiss Army Knife). That program can import files with gps locations. When I start the import, gsak starts a cmd.exe, which starts a conversion program that will import the gps entries. That program is xmlfw.exe. That last program hogs the cpu to 100% and will not end. When I manually kill it, the import to gsak continues like normal. The problem is traced to comodo beeing installed. When I uninstall CIS, the program works fine. With CIS installed, the 100% cpu occurs. I’ve tried to make all of gsak trusted, but that does not help. Disabling the firewall and defence through the taskbar also does not help. I have to uninstall CIS completely.

Any suggestions?

Best regards, Peter

What in particular are you having trouble importing?

I regularly import waypoints from zipped .gpx files that I receive by email from a few pocket queries. I do this weekly. The last time was two days ago.

The only trouble I’ve had with GSAK and CIS is a false positive with the macro updater a few months ago. (reported and fixed)

I also have GSAK set as a trusted application. Have you tried adding xmlfw.exe to your safe files to see if that makes any difference? Perhaps also exclude it in the AV settings?

If you have any specific import scenarios, I can try testing it on my machine. But like I said, I regularly import from .gpx files and haven’t seen any problem.

I even have problems with importing the demo loc file that is with the installer of gsak. Otherwise I go to, select a couple of caches and downlaod those. If I save the file first, or open it direclty does not make any difference. I tried adding all of gsak to the safe files, without luck. I do not use the av part of comodo btw, that’s avast with me. Tried to disable stuff, but for now the only way I get the import working is uninstalling comodo.

Hmmm… Well, I ordinarily import .gpx files as they contain more data, but I downloaded some .loc files from, but they import just fine for me, so I don’t know what could be happening for you.

Something you could try. Delete the security policy for GSAK, then put D+ in training mode and import some files and see what happens. Turn training mode off after you try this.

Yeah, gpx contains more info, but I am not a paying member of GC yet. Just started this thing :slight_smile:

The training mode made no difference ???

Well… I found something else… I also had Comodo Memory Firewall running, and althoug the whole gsak stuff was in the exclusion list, uninstalling CMF allows me to use gsak with CIS, so it seems that CIS and CMF together cause the problem. CIS without CMF lets gsak run ok, but CMF without CIS also lets gsak run ok. With both CIS and CMF I get the problem…

Any thoughts about this ??

You should not have Comodo Memory Firewall installed as it is part of CIS now.

Defence+ / Advanced / Image Execution Control Settings Detect shellcode injections


OK, figures. In that case, my problems are over.

Thank you all very much for the help :slight_smile: