CIS does not clean it's self entirely from system after uninstall

Have your tried removing it in safe mode? Personally I had some issues removing certain CIS keys until I tried in Safe mode, I don’t think it was the same key though, so this may be different.

Will give it a try , and report back

Did you try the God regedit to remove them?


Option four has steps for the registry.
Take Ownership of a File, Folder, Drive, or Registry Key in Windows 8-eightforums

@ captainsticks

Tried this solution and does not work (Pc’s in disrepair is XP and Win7) . Take Ownership works for [HKEY_LOCAL_MACHINE\SOFTWARE\COMODO\CIS\Installer\Sym_Cam] but the child of this is “CIS” and is not changeable at all.

Yes I have tried this options as well and does not get the key to change Ownership with subcontainers and objects.

Hi ghostza,
The mention entry was in my registry while CIS is installed, however uninstalling CIS the conventional way with no other 3rd party uninstallers/cleaners etc also removed this key from my system. (Screenshot)
Yes there were still some other benign entries in other locations.
With no other 3rd party cleaning or manual cleaning CIS re-installed with no issues.

My personal opinion is to stay away from any 3rd party uninstallers, I think they are potentially disrupting the conventional uninstall process resulting in more trouble than they are worth.


[attachment deleted by admin]

Hi Guys,

I would also like to inform you that we are currently working on CIS troubleshooting uninstallation tool as well, I will let you know the details soon :-TU

Kind Regards

Brilliant :-TU

Glad to hear this :slight_smile:

Happy to hear this . Thanks

No 3rd party uninstallers used. This was Pc’s that have been running CIS from version 6 and have done all the updates till now , due to heavy slowdowns after upgrading form CIS7 to CIS 8.2 I uninstalled and wanted to Re-install to get slowdowns sorted and ran into this problem.

I believe that most 3rd party uninstallers run the application’s standard uninstall first and then clean up leftover items from the registry and hard disk. They therefor cannot “disrupt the conventional uninstall process” because it has already finished before they delete anything. The only risk is that they might delete something belonging to another program. Most of them allow the user to select which of the detected items should be deleted.

Are the .temp files benign? What about the issue where CIS always remembers it’s previous (first) installation in the logs? I have never been able to solve this, but only with a reinstall of Windows.

Hi MartiusD,
This is not entirely accurate, some programs uninstallers (CIS) requires a reboot for the process to complete.
This uninstall process can easily be disrupted by allowing the 3rd party uninstaller to take over the uninstall process before the programs own uninstaller finalises, which could be removing vital data, files and entries required for the completion of the process which occurs during reboot and in my opinion could easily be resulting in possible corrupt uninstallations.
No disrespect to Chiron or Revo intended.
Example below:

Kind regards.


I don’t think my last post was very clear, but maybe I can explain further. Why are all of these .tmp files left in the Windows Installer directory after CIS uninstall? They appear to record the first date of CIS installation and are also signed by Comodo. Why doesn’t Windows installer remove them after uninstall? I’ve seen these left over on some of my older systems that had CIS 8.x installed on them.

Any ideas? They are all several copies of the same file, either 838 KB or 256 KB and many share the same creation times.

[attachment deleted by admin]

Hello Netguy,

CIS does not create nor delete anything on this directory you mentioned: ‘C:\Windows\Installer’ according to the QAs .

Kind Regards

But the files are created after CIS install. Why are they signed by Comodo? Is this a installer issue?

Hello Netguy,

‘C:\Windows\Installer’ this is system directory. All created *.tmp files with Comodo digital signature in this directory do not concern our installer.

For your information
Kind Regards

Thanks BuketB for the clarification. My question however still remains unanswered, why is it that after you uninstall CIS and then reinstall the program and open “View logs”, select any category (Antivirus, Firewall, Defense +, etc) and on the drop down filter select “Entire Period” CIS will show logs since the very first time since it was installed even if you installed in weeks ago and preformed a “Clean” reinstall.

Is there anything I’m missing or is this intended behavior?

-Reinstalled CIS today-
Added image

[attachment deleted by admin]