CIS Does Not Appear in tray

I have been using CFP on both my machines for a few months and have been pleased. I then got the update notification and proceeded with the update. It took forever even though I have broadband connection. After completion, neither machine would boot correctly and I had to do a system restore on both. I then uninstalled CFP and reinstalled CIS with the new version. One machine now seems ok but the other is strange. After reboot the CIS icon does not show in the tray but if you look at the taskmgr, it shows CFP.exe is running. If you click on the CIS desktop Icon it comes up on the desktop and in the tray and stays in the tray when you close the desktop window. I checked the startup file and it is starting with the -h suffix. SafeSurf shows as a running process but only shows up in the tray from time to time.

Did you do a clean install ? or did you import your old settings ?

Clean Install…

What OS/Version(s) are you running x32/x64 ?

XP Home 32 Bit. My other machine, that seems ok is XP Pro 32 bit.

Can you try to run the Diagnostics on the Misc page on the system your having trouble ?

Diagnostics says it did not find any problems with the installation…

Okay, are you running both systems with a normal of administrator account ?

Yes, I am administrator on both machines.

Can you set Firewall and Defense+ to disable and reboot see if this helps ?

See this thread about missing icons. Either that or a race condition when you have too many things trying to stick their icon into the tray on startup. Have seen is quite a couple of times with other applications, it’s a temporary issue mostly.

To answer Ronny, Disabled both and rebooted. No change. No icon. Clicked desktop icon and checked status and both were disabled. I switched them back to CleanPC.

To answer doktornotor, I only should have four (4) icons in the tray. 1. SafeSearc 2. Local Area Connection. 3. FreeRam (a RAm Manager) 4. CIS. I would not think there would be a “race” condition. and I’ve never had “Hide Unused Icons” turned on. My other machine. that is ok, has the same items in the tray.

I had the same problem.
I found help under:

Hope it helps you too …


Tried it but errored out. Probably because I’m running XP not Vista.

This can’t be the reason it worked here on XP Pro (Service Pack Version 3) 32 Bit

Did you delete the empty lines in the bat file?
It should look like the attached txt file just change restore_icons.txt to restore_icons.bat


[attachment deleted by admin]

I downloaded your txt file and renamed it and here is what happened:

Line 1 error - to many command line parameters

Line 2 error - to many command line parameters

Line 3 error - “taskkill” not recognized as an internal or external command, operable program or batch file

This was on my machine running XP Home 32 bit SP3. This being the machine that has the tray problem. Out of curiosity, I sent it over to my other machine which is running XP Pro 32 bit SP3. Line 1 and Line 2 displayed the same error but Line 3 functioned. Taskkill must exist as a command in Xp Pro and not in XP Home

To but an end to this thread, Miraculously, this AM both the SafeSurf and CIS icons started showing up in the tray. For how long, who knows???

Strange, could be some sort of boot “timing”, you did not change anything ? install/uninstall sofware, ran windows updates etc, booted with a usb drive attached etc etc ?

No, I just shut this machine down last night and when I booted it this AM, the tray was ok. I rebooted 3-4 times and now it is ok every time. Go Figure…

Don’t break your brain on it, it still are computers (:WIN) and they have strange habits sometimes.