CIS causing shutdown function to fail + misc

Hey all,

I’ve been messing around with CIS versions the last couple of days (more like weeks actually) since all of them seem to totally prevent my computer from shutting down or restarting. As in, you can click the shutdown button a thousand times but it just ain’t happening. Even a “shutdown -r” in dos doesn’t work, it did on one random occasion forcing it but meh, that’s way to much hassle.

First of all, the only other internet security program I have running is the latest MBAM, all upcomming problems exist with and without it enabled or even started. Everything is running in Win 7 x64, no VM’s or whatever just a clean PC. Also please note that everything works fine with comodo uninstalled in each scenario.
Can I provide logs, no, no killswitch kind of logs available cuz that doesn’t work (see below), dumps I guess that’s possible if really needed.

So let me work my way down versions.

7.x doesn’t work at all, totally freezes up my computer after the reboot a fresh install (I already confirmed that problem the moment v7 was released but figured I’d have a look and see if something was fixed), so, safemode, uninstalled with Revo uninstaller, ran the CIS uninstall tool, reg cleaners etc…

6.x not that stable over here, lots of annoying little bugs but fine, if it works it works, and it sort of does but I can’t restart or shutdown at all. Forcing restarts with things like ProcessHacker instantly slams me with a “no permission” so I can’t do that either, dos shutdowns fail aswell. Uninstalled with Revo, ran the CIS uninstaller, reg cleaner etc…

5.12 (this is as low as I went) shutdown problem is still there, also comes with free “can’t load MBAM, you might have a rootkit, let’s scan your entire computer for 5 hours” messages on every single boot. Instantly solved if I disable Comodo Defense+, which is the whole reason I even use an ineternet security suite because firewall wise I’m already protected by a double layer firewall (basic router iptables firewall and an advanced one I set up myself).

So, end of the line, my comp works super without CIS installed lol.

I ran pretty much every diagnostic tool I could think of before even noticing it was a Comodo issue, ran multiple virus scanners, malware programs etc. etc. from USB boots like Hiren’s boot disk and such, nothing was found, computer is clean so that’s not an issue either.

It seems like alot of permission issues but I’m not authorized to change anything because Comodo will block me doing so, which is great, if the rest of the program actually worked so you wouldn’t have too :stuck_out_tongue:

Anyone any ideas?
I pretty much gave up on 7.x but maybe a fix for some lower version. It did work in the past, it never worked great on this comp (comodo has always been a bit jittery and looks like it just gets worse and worse with each update) but not being able to shut down or even your windows updater to be able to shutdown your computer kind of makes it a gigantic problem.

This may be the problem:

On the last page of the topic Mouse1 says:

Just to add that the devs said it was fixed on Vista machines only. So still present after Vista.

So doubt it’ll work for Win 7, thanks though :slight_smile:
Plus I’m in “Clean PC” mode on uhmm v5.12 atm, problem still exists, I have this exact same problem no matter which version for CIS I install, it just ain’t shuttin’ down. I actually clicked shutdown right when I made this post. I’m using that computer right now, I’m still waiting lol.
I don’t even GET to the shutdown screen, I just stay in windows clicking on shutdown (or typing shutdown -r in dos, whichever).

Bumping this.

The only way to trigger a shutdown is by manually typing “shutdown -r -f” and thus forcing a shutdown.

New annoying bugs seem to rise as I go, for example, any SSH connection gets shut off at a random moment in time and becomes unreachable, need to reboot and then it works for a while again.

This is the same in any version of CIS with and without loading settings.