CIS breaks fingerprint logon

I have a Lenovo T500 with Win7 Pro and use a fingerprint reader for logon. I used Zonealarm Extreme on this computer for quite some time, but yesterday completely uninstalled ZoneAlarm and installed CIS 5.3 instead. There is no other Firewall or scanner enabled. I have a major problem with the logon process: it starts normally waiting for the fingerprint system to load, but after several minutes a regular, small logon icon appears, and after a few minutes more the password entry field appears. It takes about 5 to 7 minutes to get to logon. After I have logged in the fingerprint reader works fine for accessing secure websites, and I am pleased with CIS so far as well. The current long boot time is not acceptable and I am wondering how can I get the finger print login to work again?

Update - when I set D+ to training mode the boot process slowed down even more, and eventually froze at the “Welcome” screen. I then booted to safe mode, set Firewall to training and disabled D+; I was able to logon with fingerprint feature with this configuration. I will try the next boot with everything set to “safe” mode again.

hey and warm welcome to comodo forums Merlin!

Please download ZA removal tool and use it as admin in safe mode.

If you know what file this fingerprint reader uses add it in Defense + rules (CIS —> Defense+ —> Computer Security policy)

Tell me if this helps.

Valentin N

Can you please see what happens if you disable the option to login with the fingerprint reader?

That way we can identify whether this problem is related to that particular file or something about your particular system. If that is the problem then there are a few fixes we can try.


Thank you. It booted fine again today with everything in safe mode. I think the solution is to put the firewall into training mode before rebooting after Comodo is installed.

Please only put CIS in Training Mode for short periods of time; as in a couple of minutes. In Training Mode it will rules for each and every program including malware.

Use Training Mode only for program that require “tricky rules”.

I happen to come across this thread while on Google.

I am using a ThinkPad X200 (Windows 7 - 64 bit) with Comodo Free Firewall installed. Once I installed it, it totally broke the fingerprint logon.

I tried to isolate the problem by uninstalling and reinstalling Lenovo Fingerprint Reader software but to no avail. I tried merlin666 solution but nothing happened. I tried to shift the slider up and down to test each and every one but nothing change. Next I tried to add the path for the fingerprint software as a trusted file as well as the Lenovo authentication service but it did not solve my problem.

However, once I log on and everything is running up, when I log off and log in (w/o restarting the system) or lock the computer, the fingerprint reader works fine. I can use it. So the only problem I could think of would be somehow Comodo is not ‘talking’ to the fingerprint reader software when the system first boots up.

Before I re-formatted my system, the previous version of Comodo (just before 5.3.181415.1237) worked well.

I am at my wits end of what I need to do to get it up and running.

In the meantime, I have disabled fingerprint log on for my system. Any advise on what I should do? Thanks in advance.

Hey and warm welcome juzernie! :slight_smile:

to all…

see if this might help.

Valentin N

Hi Valentin,

I tried to see if I could follow the remedy steps as outlined in your link but I regret to say my system does not have the files which are similar to the thread starter. So it is back to square one (which is to disable the fingerprint log on).

Is it a bug? Thanks.

And you have made sure that you have 64 bit version and not 32bit?

Valentin N

Can you please check your Defense+ logs and see if there are any entries related to this?

yeap positive. my os is windows 7 professional 64-bit.

yeap that was what i did as well. i figured out if i go there it could tell me what it was blocking. so i added any files that the fingerprint log in was using. and they said the files are already in the safe list.

let me try turning on the fingerprint option again to see if it works after letting it ‘rest’ for a few days.

You could try to is to but d+ in training mode for some min so that CIS learn about the fingerprinter.

Valentin N

Does any of the workarounds in App. is not working correctly, but does not seem to be s/boxed. What to do? [v5] bring a solution here?

I have the same problem as juzernie, I think it may be caused by the firewall features,
everything is working normally when I disable the firewall features
Does anyone know how to fix it, many thanks!

Did you try the suggestions in my post right before yours?

thank you Eric

i try to change D+ to training mode, then nothing happen =0=, my fingerprint also dosen’t work when booting up

Did you check to make sure there were no rules already in place regarding your fingerprint scanner prior to trying training mode?

yes, i added all fingerprint file to trust file, it still cannot use when booting up
i try to disable CIS feature one by one, when i disable CIS firewall, my fingerprint back to normal

doesn’t anyone know how i can make my fingerprint work with cis firewall?