CIS alters UEFI setting preventing boot after update to CIS

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:Have not tried, do not like failing to boot. Will try when next update is available.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Update to CIS and reboot.
2:I am sure the environment is most important

One or two sentences explaining what actually happened:
Updated to CIS, rebooted to a 0x0c000000E boot failure - A needed resource is missing. The boot device (a RAID0, boot drive) was not detected. The UEFI revealed that the CSM (Compatibility Service Module) had been enabled. I disable CSM to force a UEFI only boot. With Legacy forced (CSM Enabled) the RAID0 was not detected. Boot went fine after Disabling CSM.
One or two sentences explaining what you expected to happen:
Normal reboot.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Not aware of incompatibility problems.
Any software except CIS/OS involved? If so - name, & exact version:
Don’t know. Googling the error code yielded lots of boot failures. I suspect W10 has done something.
Any other information, eg your guess at the cause, how you tried to fix it etc:
Fix is easy - Disable CSM.

Exact CIS version & configuration:
CIS and default.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Did not uninstaller. Keep CIS update regularity.
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Fatal1ty X399 Pro Gaming, TR 1950X, 3xSamsung SSD 960 EVO, G.SKILL FlareX F4-3200C14Q-32GFX, Windows 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler, Radeon RX580, BIOS 2.00, 2xHDDs WD
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

[center][u]C W10 x64 1709.16299.192 to CIS

Thanks for filing a bug report, team will have a look.


Hi johnhc,
We don’t touch boot configuration.

After you install CIS and before you re-start, please rename following file:

And see if issue can be re-produced.


Thanks, umesh. I never really thought CIS reset my BIOS CSM setting directly, but apparently W10 can. CIS is doing something that is triggering Windows to enable CSM (Compatibility Service Module - enables Legacy boot - I need UEFI ). I will try to remember to rename C:\windows\system32\drivers\cmdguard.sys after my next update and before Restart. Thanks much and enjoy, John.

Please check with Comodo Internet Security v10.2.0.6504 - BETA Thank you.