CIS 8.2.0.7403? the latest ver. BSODs non-english version windows 8.1 64bit

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
I reinstalled OS. so I can’t get more BSOD.

To reproduce use windows 8.1 64bit non english version with CIS 8.2.0.7403 with adobe flash player 18? to 19 version in both comodo dragon and internet explorer, HIP safe mode, custom rule firewall, autobock at blocked and viruscope enabled.
avira free updated to the latest.

use virtual desktop and adobe flash player in it. then try to delelte virtual desktop then I get BSOD service exception possible culprit is said to be cmdguard.sys.

if I only use html? player in youtube deleting virtual desktop doesn’t BSOD my OS but if I ever use adobe flash player for more than 2 minutes, deleting virtual desktop BSODed my OS.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: install CIS 6.2 something in non English version windows 8.1 64bit and upgrade it to 8.2.0.7403. in former CIS version, I didn’t have BSOD when trying to delete virtual desktop after using adobe flash player 18 or 19? inside virtual desktop
2:
3:
One or two sentences explaining what actually happened:
? - 10 BSODs service exception? error caused by cmdguard.sys when trying to delete virtual desktop after using adobe flash player 19 PPAPI and internet explorer adobe flash player 19 ver.

  • Failure to initiate comodo uninstaller process and comodo installer process with CIS prem installer 8.2.0.7403 in NON ENGLISH WINDOWS 8.1 64BIT VERSION

  • somehow managed to reinstall CIS 8.2.0.4703 but it doesn’t work properly.

[b]One or two sentences explaining what you expect

If a software compatibility problem have you tried the advice to make programs work with CIS?:
? no
Any software except CIS/OS involved? If so - name, & exact version:
? adobe flash player 18, 19
Any other information, eg your guess at the cause, how you tried to fix it etc:
? adobe flash player, updated 18 to 19 but still BSODed when trying to delete virtual desktop

B. YOUR SETUP
Exact CIS version & configuration:
? 8.2.0.7403
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
? safemode HIPS, autosandbox blocked, firewall custom ruleset, viruscope enabled
Have you made any other changes to the default config? (egs here.):
? added couple of custom autosandbox rules not interfering with default rules, maintained default rules at the same time.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
? updated to 8.2.0.7403 from CIS version 6.2 something.
if so, have you tried a a a clean reinstall - if not please do?:
? tried clean reinstall of CIS 8.2.0.7403 on my non english windows 8.1 64bit, failed at 1st try, managed to reinstall at 2nd try but CIS 8.2.0.7403 didn’t sandbox files and registries inside the virtual desktop
Have you imported a config from a previous version of CIS:
? no
if so, have you tried a standard config - if not please do:
?
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
? windows 8.1 64bit NON-ENGLISH VERSION, default UAC setting, admin accout, sandboxie installed but sandboxie service was disabled at all times since I use virtual desktop only.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system: avira free version updated to the latest updates, real time protection enabled.
a=avira free version updated to the latest updates, real time protection enabled.
b=installed but uninstalled malwarebyte free version.

Summary

  • 10 BSODs service exception? error caused by cmdguard.sys when trying to delete virtual desktop after using adobe flash player 19 PPAPI and internet explorer adobe flash player 19 ver.

  • been using the same setting as proactive protection, custom ruleset firewall policy, safe mode HIPS, auto sandbox at blocked setting, default windows 8.1 UAC setting

- updated from 6.2? CIS cos it was the only version in 2014 JUN that worked with windows 8.1 64bit.

  • Failure to initiate comodo uninstaller process and comodo installer process with CIS prem installer 8.2.0.7403

  • somehow managed to reinstall CIS 8.2.0.4703 but it doesn’t work properly.

- windows 8.1 64bit non english version

  • all HW drivers BIOS, chipset drivers updated to the latest, both adobe flahs player in internet explorer and comodo dragon updated to 19 verson.

  • Dell inspiron 15 3xxx series laptop 8g ram, intel HD graphic, nvidia gt840m 2g

Looks like the latest CIS premium installer comes with bugs that prevents windows 8.1 64bit non english language version from both installing and uninstalling.

I’ve read in some thread in this forum that recent CIS has a problem with non-English windows 8.1. About a week? ago, I updated CIS to 8.2.0.7403 and problems starts to happen. Whenever I tries to delete CIS virtual desktop, it gave me multiple BSODs with service exception sth.

Analyzing memory dump, I found out possible culprit was cmdguard.sys. I updated my windows 8.1 64bit non english ver. to the latest updates, and all the other HW drivers to the ones vendor is providing. It looked like using adobe flash player inside virtual desktop BSOD the OS, so I updated both dragon PPAPI adobe falsh player and internet explorre flash player to the latest 19 version. BSOD still persisted. I had about 9-10 BSOD when trying to delete virtual desktop after using any adobe flash player files. If I didn’t use adobe flash inside virtual desktop cmdguard.sys didn’t BSOD my OS when trying to delete virtual desktop.

So I decided to uninstall CIS 8.2.0.7403 and initiated uninstall process with iobit uninstaller 5 portable app downloaded from portableapps.com? Since CIS 8.3.0.7403 seems to have an issue with both INSTALLING AND UNINSTALLING IN WINDOWS 8.1 NON ENGLISH VERSION, CIS’s own installer didn’t even start.

After the failure of CIS’s own uninstaller file, Iobit uninstaller 5 portable started deletion of remnants of CIS files and registries. I went to safe mode and used CIS removal tool 2013 and CIS removal tool 2014 mod version? to erase remaining files and registries.

After that I reinstalled CIS prem 8.2.0.7403 somehow miraculously. I thought everything got back to normal, but I was dead wrong, newly installed CIS didn’t even sandbox files and registries even when I am using virtual desktop.

Then I reset my windows 8.1 to default setting.(reinstalled OS) I downloaded from cnet CIS 7.0 version 2014 and CIS 8.2.0.7403 because connection to comodo homepage was terribad disconnecting download attempts about 10 times.

When I tried to install CIS premium installer 8.2.0.7403, it gave me “exception error” and didn’t even start installing process. Back then I changed my OS’s unicode? langugae setting to english even though base language of my OS is language other than english, because I read somewhere in the forum that CIS outright malfuction in non English windows 8.1.

Whatever I do, CIS 8.2.0.7403 this time refused to even initiate installing process, so I went with CIS prem 7.0 version. It went flawlessly and now I just unticked CIS auto update setting and use custom firewall policies and clean computer defense+ setting only to avoid conflicts.

It seems like lots of other people who’s using non-English version windows 8.1 with CIS 8.2 are having issues installing, uninstalling, or even using the program as intended.

I’ve been using CIS for several years now since win vista 32bit days, and I have never encountered problems with this magnitude(about 10 BSODs) It really looks like CIS 8.2.0.7403 have SEVERE issues with Non English version windows 8.1 64bit and I really hope this gets resolved in the future updates so as not to BSOD non english version windows 8.1 repeatedly.

All bug reports need to be formatted using the required format which can be found here:

https://forums.comodo.com/bug-reports-cis/required-format-for-reporting-bugs-t102284.0.html;msg743135#msg743135

Please feel free to reformat your report and we can continue to process it.

Thanks

I’m guessing it’s a duplicate of Bug 1372. What do you think @alphaniner ?

Thanks.

Thanks for taking the time qmarius, mine didn’t give me 1603 error, it gave me a few 1683 error. What’s more dreadful is that CIS 8.2.0.7403 gave me multiple, about 10 BSODs possibly related to cmdguard.sys according to an analysis tool.

After I reinstalled win 8.1 64 bit non english ver., I tried to install the latest CIS prem installer, comodo firewall installer(both same 8.2 ver.) but both gave me this "exception sth sth several numerical error codes other than 1603 or 1683. It didn’t even start the install process. At the time, I changed my unicode system locale? language to us english since I thought it might alleviate the issue.
One more thing to add to this is that I didn’t format harddisk to reinstall OS, I chose the option to leave saved files intact.

I am not sure if my problem was specific to my laptop, but from what I’ve gone through, CIS 8.2 seems to have some serious flaws working with non english ver. win 8.1 64bit. Fortunately 7.0.xxx version of CIS works flawlessly with newly installed OS, but I am utterly dreaded to update it.

Could you check if your CPU supports SSE2 ?

Thanks.

I am using intel i7 4510U and it says it supports SSE2 on the specification page. My laptop is dell inspiron 3574, i7 4510U, gt840m, 8g ram, 26g fixed page file size is being used.

It seems your CPU does support SSE2 (a requirement for the new version). #reference

Just to check-- Did you experience Error 1603 as well?

Please change to English language for now. For further investigation, you need to attach a complete memory dump.
Guide : Create a full memory dump

Thanks.

only got 1683 and several 4-5 digits exception codes other than 1603 or 1683 when 8.2.0.7403 cis prem installer refused to start installation process, and this happened even when I changed my system unicode? locale? to english.

can’t afford BSODs now, will update it later, thanks

As there has been no response, I will move this one to “Resolved” section.
Thank you.