CIS 5 incompatible with Daemon Tools etc.

I noticed that after updating my Comodo Firewall to version 5, both Daemon Tools and Alcohol 120% stopped working. After uninstalling Comodo they work just fine. I only had the Firewall installed, Defense+ and Sandbox were disabled. I have 64-bit Windows 7.

Now I’d like to install CIS 4 again, but I can’t seem to find the 64-bit installer anywhere. Can anyone help me with that? Otherwise I’ll just have to live with Windows Firewall or install another Firewall software.

Maybe the files were automatically sandboxed and you need to make them trusted ones.
Can you check?

All other programs worked without any problems at all, and I did have sandboxing disabled when I right clicked the Comodo tray icon. Also this never happened with version 4. Do you think that they still might have been sandboxed somehow? I didn’t change any settings during of after the update to 5. I might try installing CIS 5 again someday, but probably not right now. I just don’t feel that a software should automatically start disabling my programs without even informing me about it.

Anyway, whatever created the problem probably has to do with the SPTD driver, which is used by both Daemon Tools and Alcohol 120%.

Other people are having the same problem:

So it doesn’t seem to be about sandboxing.

Does adding the DT installation folder to the Exclusions of shellcode injections help?


i confirm the same problem on 2 computers. after updating commodo Daemon Tools can’t run anymore
(Error Message: No STPD Driver installed of kerneldebugger is on)

I’m also having the same problem.
Does anyone have a solution yet?

Did any of you try this?

I was having the same trouble, and I only use the firewall component (Defense+ is disabled and I use a separate anti-virus package). I chose to install only the firewall but for some reason Defense+ was installed anyway. Even though Defense+ is disabled I was only able to run Daemon Tools successfully after I added the Daemon Tools directory to the shellcode injections exclusion list, as per the instructions in the previous post.

Cheers for the tip EricJH!

I wonder why it gets blocked even when Defense+ is disabled. Anyway, it’s good that some solution was found, but I’m not installing Comodo again before it’s fixed properly. Defense+ should not be blocking anything at all when it’s disabled.

Btw, does anyone know of a website where I could download old versions of 64-bit CIS? I can only find websites that have 32-bit versions available.


I solved the problem by checking the option “Desactivate the Defense+ permanently (Requires a system restart)”.

You can locate this at tab Defense+ → Defense+ Settings → (on new window) tab General Settings.

Totally disabling D+ that’s not a good solution.

Hi everyone.

I had the problem until 5 minutes ago. Just execute the following steps:

  1. Open the Defense+ Settings. And push the “Exclusions” button on the bottom right. There will be opened a list menu.
  2. Select Add → Browse
  3. Add the whole directory of Daemon Tools
    (For 64-bit Win users: C:\Program Files (x86)\DAEMON Tools Lite)
    (For 32-bit Win Users: C:\ProgramFiles\DAEMON Tools Lite)

-Now execute DTLite.exe. It should work. Check the system tray to observe the DT icon.

Hope this helps.

I’d just like to confirm that adding the directory to the image Exclusions of shellcode injections. In my case, it was Deamon Tools Pro that wasn’t working, but is now.