CIS 5.3 bug [NBZ]

The bug/issue

  1. What you did:

Comodo IS notified update so I updated and rebooted computer later.

  1. What actually happened or you actually saw:

After reboot net works fine except browsers (FF3.6.13 and IE8) can’t get to net if firewall is set to safe but browsers work fine if firewall is set on training, Windows Live Messenger, Mirc and ICQ work normally on firewall’s safe mode.

  1. What you expected to happen or see:

I expected browsers working normally after update as it did before reboot which update needed.

  1. How you tried to fix it & what happened:

I set firewall on training mode and browsers work normally.

  1. If its an application compatibility problem have you tried the application fixes here?:

Not a compability problem.

  1. Details & exact version of any application (execpt CIS) involved with download link:

Firefox 3.6.13 and Internet Exploer 8.

  1. Whether you can make the problem happen again, and if so exact steps to make it happen:

Yes I can make it happen as many times I want just by setting firewall on safe mode and browsers stop working.

  1. Any other information (eg your guess regarding the cause, with reasons):

CIS FW blocks http-protocol on safe mode.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:

1-4 none.

Your set-up

  1. CIS version, AV database version & configuration used:

CIS 5.3.181415.1237, AV db updated 30 mins ago. AV is disabled cause I use Avast (6.0).

  1. a) Have you updated (without uninstall) from CIS 3 or 4:


  1. a) Have you imported a config from a previous version of CIS:

Yes but before last update which CIS notified all have worked properly.

  1. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):


  1. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =

D+=enabled, Sandbox=disabled, Firewall=enabled, AV=disabled.

  1. OS version, service pack, number of bits, UAC setting, & account type:

Windows XP 64 bit SP 2, no UAC, Administrator.

  1. Other security and utility software installed:

Spybot+teatimer, Avast 6.0, Adaware Internet Security Free.

  1. Virtual machine used (Please do NOT use Virtual box):


Spybot teatimer, Avast 6.0, Adaware Internet Security Free and CIS all potentially monitor the same processes and files, that’s asking for trouble.

  • CIS 5.x, Avast6 and Adaware9 all have AV-components (CIS AV disabled, that still leaves 2 conflictin AVs)
  • teatimer, AdAware and CIS Defense+ all monitor running processes (CIS Defense+ disabled, that still leaves 2 process monitoring applications).

Thank you for your issue report.

Moved to verified.

Thank you