CIS 4 - doesn't ask whether it should block applications

situation/config: I have just installed CIS on Win 7 64bit. I’ve chosen custom policy mode, alart settings to hight and everything else tagged.

what I would like: I’d like comodo to ask whether a new programm can access the internet. no matter what program. For instance, I’ve just started winamp portable and it did NOT ask whether it can access the internet - but it did because it suggested an update. I want to have the control of what “calls home”.

thank you very much in advance for your kind help!

Take a look in Global Rules. Maybe you have that default rule Allow All Outgoing.

It’s either the default outgoing rule or the vendor is in the trusted list and the app is whitelisted. In either case, you will get no alerts and outgoing will be allowed automatically.

Web access for individual programs is handled by application rules not by Global Rules.

First you need to disable “Create rules for safe applications” under Firewall → Advanced → Firewall Behaviour Settings → General Settings.
Second in the same place set the slider to Custom Policy.
Third step to get the maximum control is to delete the All Applications rule under Firewall → Advanced → Firewall Behaviour Settings → Application Rules.

Now you are in control.

I don’t think this is correct since uTorrent does not accept incoming connections unless the block all incoming global rule is removed.

Hi and thanks for your help. Unfortunately, I already had done all the steps above. I’ve deleted all rules, everything…comodo asked me tones of questions if I start a programm the first time, but all related to the registry etc. nothing about web access.

the only internet related questions are about IP addresses. so when I start firefox the first time, it says that “System” or “Windows Operating System” tries to access source IP xzy using UDP protocoll etc. but it doesn’t aks whether firefox can use the internet!

is that behaviour normal?

Try changing your active config to PROACTIVE.

Did you set the slider to Custom Policy mode as I asked under point 2?

Go to Firewall → Advanced → Firewall Behaviour Settings → General Settings → Alert settings → move the slider to High. Now you will more alerts when programs access the web.

When yout

Firefox is a trusted program so it will not produce alerts.

That’s why I suggested to set the Firewall behaviour settings to Custom Policy mode. Then it will also alert for safe applications.

yes, I’ve done all this…

also set it to Custom Policy mode and proactive as suggeted above…

it still does not ask me whether a program is allowed to access the web. for instance, I downloaded picasa, installed it and told it to check for updates. Comodo asked my some question while starting the program whether it was allowed to “use” the PC. However, it never asked me whether picasa can access the internet. isn’t that strange? so it directly told me that it is up-to-date…I just want it to be blocked. and since I changed a lot of settings, it was NOT automatically regarded a safe application!


the only questions with regard to IP addresses come from System or Windows …not one program has asked…

When in Proactive with Custom Policy Mode the only thing I can think of is that there is something not quite right with your installation.

The only thing I can think of right now is to ask you to do a clean install. In case you are going to you can export your current active configuration under More → Manage My Configurations. After installing you can import it (assuming you are not importing your problem to the fresh installation).