CIS 4.0.X still causing High DPC Latency issue

I am still getting High DPC Latency issues with the newest CIS Firewall. I only installed the firewall. I use the latest Avast for my anti virus solution. I am running Windows 7 Professional x64. I am positive it is CIS because I used to use CIS on this same box, and it worked fine. After an CIS update last fall, I started getting weird slowdown when playing audio or video. I was able to isolate it to CIS. I removed CIS and ran just Window Firewall for about 6 months with no DPC latency issues. I was then infected with some malware (probably due to not running a third party firewall solution like CIS) so I reimaged my computer a couple days ago. I thought I’d give CIS a try again as the revision history states that the DPC Latency issue was fixed in a past revision. But to my dismay, the issue is still there.

My computer is on 24x7 and serves media to various XBMC boxes in the house. So I pass a lot of traffic. I was under the impression that this issue was fixed a couple revisions ago. Is this still a problem? I love CIS and would hate to switch to another package. But I may have no choice. Is there some sort of work around? Or something I can do to prevent the high dpc latency after prolonged uptime? Any help would be appreciated.

* Intel C2D E7500 x64 CPU
* Windows 7 Pro x64 (with all patches up to date)
* Comodo 4 and Avast 5.0.462
* After prolonged uptime, i start to hear popping and crackling when I listen to music or watching videos.  When I browse the internet using Firefox 3.5.8 and any time Firefox tries to render a page, my music or video will stutter.  I've already attempted a fresh OS install.  The only thing that seems to work is removing CIS.  Then the issue goes away permanently.  I've also run the DPC checker and my DPC Latency is consistently around 5000.  However when I uninstall CIS, my DPC Latency remains unchanged but over a period of time, the DPC Latency slowly returns to normal at around 300 and remains there (Note:  I uninstalled CIS last night and i realized I have a download going that I didn't want to lose, so I never rebooted. I had the DPC Latency Checker running the entire time.  When I woke up this morning, the latency was normal.  Even without a reboot.)
* Specific steps you have taken to try to resolve it.
* Defense + is on safe.  Firewall + is on safe mode.  No other custom entries.
* No BSoD
* I am running on the Admin account and UAC is enabled.

I will move this to the bug boards.

Can you add the needed information as described in Important: how to submit bugreports (read this if you want them fixed).

Thanks in advance.


I reinstalled Comodo Firewall 4.0.138377.779. For snits and giggles I tried just running the firewall and disabled Defense +. After about a week of uptime, my DPC Latency remained normal. So I thought my problems were gone. However I ran emule for about an hour at which point my DPC latency went through the roof again, causing stuttering of video and audio files. I shut emule off and almost isntantly, DPC Latency returned to normal. So, now it appears that any time I run any P2P application, I get high DPC Latency issues.

Is this related to the fact that CIS uses a large # of GDI Objects per Task Manager?


you know I had exactly the same problem with two of my customers, and it was because of two different problems, nothing to do with DPC…

First customers, exactly the same problem, solution was, I took out the CPU cooler took a toothpick and a cotton stick and cleaned the f*** cooler for over a hour(yeah I know but the customer wanted me to clean the cooler and not to get him a new one), after that everything was working fine…

Second customer, again the same problems as you, solution was a new Router, Zyxel has a connection limit of 400 simultaneous connections build in the Firmware, emule makes (depending on your conf.) 800 connections per file so the router is dying because the CPU is to week. I had the same Problems with Dlink and Netgear, working ant the solution for the customers was a Linksys Router.

As I said had nothing to do with the DPC but exactly the same problems like you are describing…


P.S. Are you in front of the computer when that happens? Do you have a Screensaver or SETI running? Had a similar problem to yours, a server was running just fine when I was in front of it, when I drove away from the customer, 5 min. after the problems came, took me a while to figure it out but it was the screensaver which was slowing down the server, turned that thing of and everything was running fine(it was a standard MS screensaver)…

Adding to the e Mule/p2p situation. I have the following settings are a rule of thumb on how to load your connection:

  • the total amount of upload for p2p and game app should not exceed approx 75% of your total upload capacity
  • the total amount of upload for p2p and game app should not exceed approx 75% of the maximal amount of simultaneous connections

The amount of total connections is not always easy to find and will usually require a Google search or email to the manufacturer of your modem/router. Assume that these days standard A brand routers/modem-routers will handle 1024 simultaneous connections you can work with the following.

My situation is a shared ADSL 2+ connection (15.3/1 Mb/s) with 7 house mates (half male/half female). We have one avid online gamer who is most sensitive to load variations. What works in my situation is to give an 10kB/s upload slot with 50 simultaneous concurrent connections to each gaming/p2p person. Notice that in this situation these things are not always execised by all at the same time. My rule of thumb will provide a workable work hypothesis that you can play with. It is not written in stone but is a damn good starting point.

I can’t seem to get the latency above 200 (have both eMule and BitTorrent running at the same time).
Win7 x64, CIS 4. I don’t think this is an issue with CIS, but maybe some other driver you are running?
I will continue to monitor my latency, btw.

At LordRayden. This is not a HSF issue. Nor is it a hardware issue. I can push this machine with Prime95 for 12 hours and my CPU will not break a sweat. And my DPC latency will not go above 200us. And I get no video or audio stutters.

The ONLY time I get this issue is when I run a P2P app for an extended amount of time. Maybe 30 minutes to 1 hour. Then the DPC Latency Checker goes through the roof. As soon as I shutdown my P2P, the DPC latency returns to normal. This in it self should exclude hardware.

Now John Buchanan brings up an interesting point. That maybe it’s a driver that’s causing it and not CIS4. However, the problem with that statement is that if I uninstall CIS4, I can run any P2P apps for hours and never see a rise in DPC latency. While I can’t say this DEFINITELY precludes a driver issue. But I can say with some confidence that it’s CIS4.

However since John Buchanan isn’t seeing the issue, I may have to conclude that this might be an issue with CIS4 in conjunction with a certain driver? Maybe my NIC driver? I dunno. I have nothing exotic installed. All fairly basic hardware. No odd programs running. This issue occurs with a FRESH install of Win 7 Pro X64 (Legitimate copy through MS Student discount program) and just CIS4 and Emule installed. Nothing else installed. So I am at a complete loss.

Below is the complete spec of my computer. No additional hardware installed.

Intel C2D E7400 [at]2.8ghz w/ ZALMAN CNPS9500 (AS5 Thermal Grease)
GIGABYTE GA-EP45-UD3P Motherboard (running latest non-beta firmware.)
OCZ Platinum 4GB DDR2 RAM (Running at stock)
1x 500gb Samsung Spinpoint HD.
2x 1.5gb Seagate HD
2x 1.5gb Western Digital HD.
Sony Optiarc DVD Burner
Corsair TX750 PSU
Antec Three Hundred Case

FYI: I run the latest memtest for 24 hours with ZERO errors and I can run Prime95 for 24 hours with ZERO errors. Idle and Load CPU temps are 28c and 45c respectively. Which is well within limits. In fact it’s down right COOL.

And the last thing I will add is, my computer was working fine for a couple months with CIS 3.9. I had NO issues whatsoever. And then one of the updates started to cause this issue. I wish I could remember which update it was. I want to say the issue coincided with 3.10 or 3.11. But not sure as initially i didn’t suspect CIS was the issue at all. In fact I thought it was a hardware issue until I discovered a thread that pinpointed CIS as the issue.

I can run mine (P2P) for over 12 hours and still not see latency above 200 (have run so many times). The driver issue would be a compatibility issue with CIS then, but not necessarily CIS nor its drivers.

For example, last year many users with certain laptops/workstations (HP I think without having to look it up), complained viciously against CIS as the cause of sound issues they were experiencing, some also stating they did not experience issues with CIS uninstalled. Many did not wish to concede it was not a CIS issue. The resolve, it turned out, was to update their audio drivers. It was a compatibility issue with an older driver, not CIS.

Egemen and his team have worked very hard to resolve any latency issues that were being caused by CIS, and they have succeeded, IMO.

yeah my latency when running a p2p never goes above 100us, so I think it has to be a driver. I would really try to update all of the drivers I could.

Just an update, but I found that Gigabyte recently released new Realtek Nic and Realtek Audio drivers. I also updated to the latest Catalyst and driver that was provided to me on the GPU manufacturers website. So all drivers are up to date. I did some more systematic testing and here is what i found.

At Rest (Meaning no P2P running).
Average Latency: 100-200us
Absolute Max: 309us

Running just Utorrent for a couple hours.
Average Latency: 150-350us
Absolute Max: 1000us (These were rare spikes and usually it only occurred when I browse concurrently.)

Running just emule for a couple hours.
Average Latency: 5000us
Absolute Max: 8000us

So this appears to be an issue with Emule for me. I am also wondering if AVAST has something to do with my DPC Latency. When I open CIS and check the inbound and outbound connections. I see Avast making a lot of connections. Both inbound and outbound. I know this is probably due to Avast’s many different network monitoring shields. I guess what I will do is uninstall Avast and install AVG and report back. I will also try different combinations of different firewalls and av software to see if I can pinpoint the cause. I am also going to try and revert back to CIS 3.9 since I don’t remember having any issues with that version (That is assuming I can find a copy). Whatever I find I will report back.

Release notes for 3.9 are here:

Direct download for x64:

Thanks for the link. Unfortunately the link is dead. However I just googled the filename and found this neat site. Thanks.

3.14 can be found here.

I’m back as well because I noticed this again too, audio skips were a telltale sign of the old nightmare coming back.
You managed fixing it once, so how did it come back?

Any hope for a resolution in the newer (and I assume better) versions?

Well i am pretty sure I still have the issue as well. However I don’t use P2P enough these days to really care. I used to use P2P stuff for foreign television shows from my native motherland (Korea.) However I have found more direct solutions, so I’ve just forgotten about this issue.

For the life of me I could not figure out what it was. I don’t have any abnormal hardware. Everything is very standard and brand named. No weird 3rd party cheapo hardware. All drivers are up to date. I’ve tried both the drivers supplied by the manufacturer and for sh1tz and giggles I used ones from MS Windows Update. No matter what I do I get High DPC Latency when running emule. Also I get it when using utorrent, but not enough to bother me.

The one thing I did replace is my router. I honestly don’t know how firewalls and dpc latency really work, but my old router had issues and maybe it was opening too many connections. Maybe replacing my old WRT54G with DDWRT on it might help? Who knows. I guess if I have time I’ll try to see if the issue is still persisting. But for now I don’t use P2P enough to care.