CIS 4.0 unable to delete custom firewall rules

My configuration is Windows 7 Ultimate 64bit with UAC enabled and I am running as ordinary user.
When I switched Comodo to User Defined Rules and tried to delete some existing rule it did not work!
It just displays message: "You need to use ‘Predefined Firewall Policy’ window to delete this item.

But it is nonsense since I defined these rules and I want to delete from 1 program rules set and not to modify profiles like Trusted Applications. Only option here is to delete all rules for application by clicking delete on application.

I found another issue with sandbox, it seams that even if I aswer: Do not use sandbox for application and click
on remember than Comodo forget my answers since I have to answer same questions again and again.

Welcome to the forum mgandalf :slight_smile:

There is a problem with this in CIS V4 at the moment you have to double click the application or edit then in the window that opens you can delete individual rules.

Could you please check if the application which you have a sandbox alert appears in Defense+ / My Safe Files


I believe this should be fixed with the version that was just released.

Yes it is fixed in the latest CIS V4 program update .779


I tried Sandbox Total Commander and during and even after I have chosen to keep program in Sandbox it is displayed within “My Pending Files”

Mgandalf please don’t use a topic in the beta board.

Locked to prevent people from kicking this topic and the original problem as in the title got fixed with the release of .779.