CIS 3.8.65951.X Problem with Windows Dynamic Disks

Hello guys,

I have trouble with CIS after I start using Dynamic disks in XP. After installation, I get the error message “The network firewall is not functioing properly” and then access to network or internet is not longer possible. Disabling Defense+ is not enough + reboot either. CIS must be removed to make it work.

Current config:
* 32 bit
* Windows XP SP3
* Antivir Premium 8.2.x
* Create dynamic disks on XP and access to network/internet is not longer possible (The network firewall is not functioing properly.)
* CIS must be removed to make it work again
* Defense+ = Safe mode and Firewall+ = Safe mode - no other modifications
* Using an account with admin rights

Hope you fix this one so I don’t need to stay on a competitor firewall.

K. regards,
Jai Sa

I have this exact problem. Took me a while to figure out it was the dynamic disk causing the trouble. Comodo is not even installed on the striped volume i am using. It is on the primary partition and i am using a separate partition to do the disk striping, but the entire disk must be set to the dynamic status for you to be able to do this. I have had trouble with several other firewalls as well with this set up. Everything works fine with it set to basic disks or with no firewall installed. I would really like the ability to use a dynamic disk and the firewall both.

Guess, I have exactly that, too. Can’t say for sure, since I already had dynamic disks prior to installing
CIS_3.8.65951.477_XP_Vista_x32, but the symptoms are the same:

  1. cfp and comagent are started, but cfp shows “The network firewall is not functioning properly” for no apparent reason, and Fix button finds “nothing wrong with the installation”.
  2. No net access. Killing cfp and comagent doesn’t help. Rebooting helps depending on the Moon phase, i.e. sometimes it’s no access completely, sometimes there is access, but network performance looks suffered and first ping in a series of pings to any host gets swallowed. Uninstalling helps.
  3. Playing around with Defence+ and Firewall+ modes changes nothing.

* 32 bit
* Windows XP SP3
* Avast! Antivirus 4.8
* Access to network/internet is impossible (The network firewall is not functioning properly.)
* CIS must be removed to make it work again
* no modifications of Defense+ and Firewall+ settings since install.
* Using an account with admin rights

Really hope you’ll fix that soon. I was looking forward to using your firewall, and got such a disappointment.

I tried it even with having a basic disk hard drive and the rest dynamic it just can’t handle it I’m switching to AVAST they claim dynamic disk support anyone else tried it?

Have any of you tried a update version of CIS? It may fix the problem.

You can get it here: .