CIS 3.8.65951.477 Won't Stop Initializing

CIS 3.8.65951.477 is becoming a continual source of frustration!!! (:AGY)

I am running Windows XP SP3 patched right up to current. I have a LinkSYS WMP54G and I am running the included LinkSYS Wireless Connection Manager as well.

I unistalled CIS version .471 rebooted my PC and then installed version .477. Restarted my PC again but Comodo hangs at the intialization stage. I have no internet connectivity as LinkSYS Wireless Connection Manager cannot startup because of Comodo. I also run JAVA program called WebScheduler, which is a DVB capture program and automatically starts up with Windows and sits in system tray. That too will not startup.

UPDATE: After about 5 minutes Comodo stops initializing but says that Comodo Agent is not running. I don’t have this problem with .471. PLEASE FIX!!!

UPDATE 2: I let it go for about 10 minutes to eventually let it do its thing. After about 10 minutes it came up with dialog boxes regarding “New Private Network Detected”, permission for JAVAW.exe to access which then allowed WebSceduler to run, and then permissions for system files. Eventually I was able to connect to the internet. Comodo then seemed to run fine even though it STILL said that Comodo Agent was not running. It took a THIRD restart, after having installed it, to get the Comodo Agent running.

PLEASE NOTE: Comodo was installed on a reasonably fresh install of XP only a few days old.

After about 5 minutes Comodo stops initializing but says that Comodo Agent is not running. I don't have this problem with .471.

hi sean,
I too had the same problem. Win XP SP3 - Comodo doesn’t show up at all in systray and PC seems to just hang - started with .471. Similar non-initialization problem.

What I did was these 3 things :

  1. used Revo Uninstaller to uninstall
  2. checked and removed the comodo registry keys given elsewhere here (if any left behind by Revo)
  3. reninstalled, but in “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run” changed the Data from "“C:\Program Files\COMODO\COMODO Internet Security\cfp.exe -h” to “C:\Program Files\COMODO\COMODO Internet Security\cfp.exe”

[That is removed the “-h” at the end. The only probem is comodo flashes the start up screen whenever I bootup, but initialization problem has stopped and it also seems faster.


have you tried to put the -h back in?

have you tried to put the -h back in?

hi John,
Yup tried it, infact today morning (in IND it is Sun morn)
what happens is that PC seems to freeze. There is a lot of HDD activity- LED glowing but nothing else happens, for a few minutes - about 5 mins. Then PC is OK, BUT, there is no comodo on the systray. When I check up taskmanager, cfp.exe and cmdagent.exe ARE running - I am able to

I have to dblclick the comodo desktop icon to get the comodo on the systray - and even then comodo says 'being initialized" for some seconds before going to sit on the systray.

Without “-h”, the flash screen pops up, but within 20 - 30 secs or so, everything is fine.

Worth a try. Thank you for your reply.

Thanx kmprasad for that bit of info - I’ll give it a go.

The other problem that I am having is that Comodo sometimes causes my PC to spontaneously restart just shortly after it has booted into windows and the windows opening theme music plays. I know its Comodo casuing this because it never happened before I installed it and secondly, I very quickly saw a Comodo error box come up just before it spontaneously rebooted. It was so quick I couldn’t see what was written in the box.

Sometimes on restart I’ll have an error message show that Winlogon had to prematurely close.