CIS 12.2.2.7036 blocking P2P W10 x64 Pro

Hello!

i decided to give this one more try and ask for help before i change my firewall to something else…

Some months ago some version update started to give issues with P2P when firewall is enabled and i started to do research about it and found many topics about from this forum and from google some random places where there were issues aswell…
Still even with those tutorials and informations i couldnt get things to work… i went back to windows firewall + eset av combo and deal with it when i have time and maybe it gets better with few updates… havent gotten any better in these past months and i might have had a security breach in my pc so i wanna have a decent firewall and i have trusted comodo for years…

My issues are with airdc++, i guess same would go with every version aswell but it only uploads, it uploads fine but cant connect when downloading… and qbittorrent download seems to work fine but uploading dosnt work…
both has forced encryptions if it helps anything… been trying lots of different settings and profiles and tested to add those in different ways… whatever i could find from internet…

so… any ideas what i could have done wrong? everything starts working fine when i disable firewall…

I assume that airdc++ is a trusted application and as such it is listed in “File List” as “Trusted” on your end. am I correct?
Can you check this?

It was at unregonized state, changed it to trusted… good point (y)

No effect tho… and Q was already in trusted state

Is airdc++ listed in “Firewall->Applications Rules”? (Use search function in “Application” bar)
Has it a FW rule attached or is it not listed at all?

It is listed and that is place where i have tested lots of different settings from udps tcps ips and so on different source ports and destination ports i have setted up… atm it


, dosnt effect is it ticked or not…

Now that you have changed the “File Rating” to “Trusted” for airdc++, you can remove all airdc++ related Firewall Applications Rules and check if airdc++ then works.
Be careful to only select (tick) the Firewall rules related to airdc++ before you click the Remove button.

Since airdc++ is now in “Trusted” state Firewall will allow in/out traffic by default.

Nah didnt help for some reason :o

Same issue as before?
Has nothing changed in airdc++ up/down traffic behavior?

It really is simple, all you need is one single global rule to allow incoming on the port or ports that the application is listening on for incoming connections. No need to set source and destination address, or source and destination ports. Based on the application rule you showed, it won’t accept connections from other people as they won’t have an IP address that falls within your home network zone of address. And once an application is rated as trusted, there is no need to set any firewall application rule as trusted apps will automatically allow all and incoming connections, so you only need to set the global rules up correctly.

This is the easiest Global Rule:

Action: Allow
Protocol: TCP or UDP (assuming both are being used)
Direction: In
Name: Airdc++

Source address: Any
Destination address: Any
Source port: Any
Destination port: the port number as in settings of Airdc++ (I assume that TCP and UDP protocol use the same port number)

You can tighten up this rule by using a destination address. That destination address could be the MAC address of your NIC or your internal IP address (only when your interal IP address is static).

Regarding qbittorrent, since this is also a trusted application there is no need to have firewall application rules set for it either.
Check if you have any firewall application rules set for qbittorrent, if so then remove all qbittorrent application rules from the list by ticking the corresponding checkbox in front of the rule(s) and then click on the Remove button.
Next, press OK button in lower right corner and try again if qbittorrent now works correctly.

Heya!

Sorry for late answer!

Looks like things are working now like they should except some random crash notifications comodo gives but those are for different topic i guess :slight_smile:

Got things working with your help! Much appreciated! :-TU 8)

Thanks alot for the help! (^^,)

You’re welcome!

:-TU :slight_smile: