CID doesn't change the language [Merged]

Hi, I’ve a problem with my CID since ver.

My OS is WinXP & Win7 x32/x64 Ultim
Antiviruses are: ESET SmartSecurity 7.0.302.26 & AdGuard antibanner.

in any other versions of CID I had not any problems with changing languages. but when came out, and my CID copy updated, the lang was ENG, when I’ve tried RUS, nothing changed. Even when I tried any other langs, still the lang of CID is ENG.

could you please tell me what’s wrong, and how can i fix it?
Mod edit: Added merged to the topic title, Captainsticks.

Hi and welcome triceratops,
Try removing the language pack from your add-ons , then restart CID and from the options menu re-select your preferred language.

After restart this should replace the language pack, hopefully in a working state.

Kind regards.

Hi, i’ve the same problem…

but i tried to change to Spanish language, but still the lang of CID is ENG.

Hi and welcome jimleca,
Try choosing an alternate language (Example English US), select OK> install now> restart and then try your preferred language (Spanish) select OK>install now>restart.


yes, I’ve tried to do it, like you say. and even when I install CID to brand new Win 7 or XP, then change my lang to RUS, it doesn’t turn on.

this doesn’t helped too. I’ve deleted langpack, restarted CID, installed belarusian, then again russian - and still - CID is english…
Reply 1 from me.

oh, thnx! this helped!

Thanks jenny66, your help is appreciated. :-TU
I am not sure why different methods are required.

No problem.
I noticed that there are such problems with a language package. (I saw on FF - en).
I wanted to check and establish a CID portable.
But I refused because CID demands DNS (screenshot). ???

[attachment deleted by admin]

thx captainsticks

but is the same, nothing change…

The language in IceDragon is set to English (United States) and I want it to be English (United Kingdom).
I go to Tools - Options - General - Set Browser Language (requires restart)
I then select English (United Kingdom) and the language pack is downloaded and I am informed that
the pack will be installed on restart. I restart the browser and again select English (United Kingdom). The
language pack again downloads and the browser restarts. Again I select English (United Kingdom) and again the
pack downloads and I restart. This happens every time I try to change the language.
Tools -Addons - languages shows
COMOCO IceDragon Language Pack 26.0.0.

I followed the advice in
but it made no difference.

It would appear that the pack being downloaded is
but the only extension that Agent Ransack shows that appears to pertain to a language extension is

I have tried doing this both as my normal “superuser” status and by running IceDragon as administrator.

Windows 7 Pro 64-Bit

Can anyone advise ?

Merged topics.

Any signs that this problems is being addressed ?

I have the same problem with my czech language. I try installing czech language, try alternate slovak language, restart CID … Language pack is downloaded, but nothing change …

Install lang pack.
go to about:config
change general.useragent.locale from en-us to that you want (example: en-gb, es-ar, es-es)

I have the same problem with russian language