CID , cant change from Yahoo search engine

I have CID on trial at the moment, its been ok I guess for the last few days, till I tried to change the search engine option. I did as requested went and typed the about config, then clicked the I will be caref… etc etc. changed the keyword , didnt work just slowed down CID, so didnt matter what search engine details I put in in , nothing changed , back to same old ■■■■ Yahoo, so I tried to disable function as per the instructions. Now CID is as slow as IE or Chrome, I can make coffee in the time it takes to load a page . My other two browsers SR Iron and Wyzo are fine and running at speed. Any suggestions ( printable )

Hmmm 23 views and no response?
Reading the forum posts I guess there are issues with this browser. After using CID solidly all day its now at the point of taking over a minute to open news sites like Reuters etc, plus I have had about 20 sites that it just cant open, screen freeze or just writes code. After reading all the hype on CID and going through the Comodo web site they must have some good software, just that CID obviously isn’t it, and it certainly isn’t supported

COMODO … Creating Trust Online… not with CID in this mess you wont, get real guys. :-TD

Hi scumbama,
I personally have no page load issues using CID, I think we need to look into what is causing this issue.

Search engines can be changed from within the right side of the address bar. (Screenshot)

Snide remarks gets you nowhere positive in life.

Thanks. :slight_smile:

[attachment deleted by admin]

Thanks for the kind words Capnsticks. Yes I may have been a bit caustic but when you are entering hour 14 in 15mins still with no success only a steady decline… well I am sure you understand . The addon section works in changing the search engine, eg you add it will work once manually then revert back to yahoo. But the bigger problem is the the slow down and the ever increasing sites that wont load. I am going to uninstall then load CID again but on another box and leave it running for a couple of days with a live news feed then go back and have a look. I dont have anymore time to play with this.

Hi Hi scumbama,
I understand frustrations can set in, no problem. :slight_smile:
Regarding page load times, could you please try with ‘Malware domain filtering (Comodo Secure DNS)’ disabled?
Configuring Advanced Settings

Regarding the search engine not sticking, are you using any other 3rd party cleaning programs?
Or does this happen upon every relaunch?

Thank you.

Edit: To eliminate any user profile issues, it maybe worth trying the portable version in step 2 of the following link.
Downloading and Installing Comodo IceDragon
Note: The portable version is independent from the installed version.

This is related to this old discussion thread. I read a 5/19/14 CID customer review (Version: Comodo IceDragon at another website ; the customer stated:

1.It forces you to use yahoo search, which must be the worst search engine in the world. you can’t change it.
2. after I used google a couple of times to search for things, it reported google as a dangerous site and it blocked it; so no matter what I did, I could no longer see google or read my emails on gmail. or use any other google site (they all stopped “existing”).

You addressed point #1 (drop down box to change search engine). But what about comment #2 ?


Oops – sorry. I see this same question about point #2 nastily (!!) asked in the “How do I unblock Google?” Thread. It would appear that blocking Google is not coded into CID as a protection against possible (?) Google tracking ? Correct ?