Chromodo no longer default browser after update

I also was surprised by this update.
On my side, the update triggered the Comodo anti-virus, which asked me autorization for every single step of the update (although I clicked the “remember my selection” button).
Now that version 48 is installed, Chromodo is not my default browser anymore. I tried to set Chromodo as my default browser, but I get a pop-up window proposing me to chose my default browser with 2 option: Internet Explorer and “Select an application on Windows Store”. I went for the windows store, but Chromodo is not available there.

What should I do to get back to a working configuration?

Why should you expect to finds Chromodo at the M$ store?
Go to the Windows settings.
Set your default browser there.
(A M$ issue)

@ John Buchanan
I am not really surprised that Chromodo is not available in M$ market, but that is the only option available when using the “quick” procedure to define Chromodo as default browser (except IE).
I went for the “long” procedure through the control panel and did not succeed either: Chromodo is not in the list of installed programs! I believe this is because I interrupted the update, fed to click 10000 times on “Allow” in the Comodo pop-up window. Note that Chromodo is installed and working fine (I am currently typing this message in Chromodo).

Is there a quick an easy way to add Chromodo in the Windows list of installed programs without reinstalling it?

Thanks for your help

Reinstalling it would be the quickest way.