Choosng Trst This App doesn't prvnt future Opera Next Elevated Alert [V7B][M816]

0-Elevated Privileges alert always appears when launching Opera Next, even when “Trust this application” is checked.
1-I failed into creating a report, see the attached screenshot.
2-Comodo Internet Security Premium Beta 7.0.308911.4080.
3-Windows 8.1 Pro x86 (up to date).
4-Custom settings near the ones suggested by Chiron via his How-To.
5-Clean install.
6-I don’t have any other security software installed on my computer.
7-Launch Opera Next (latest build: 19.0.1326.45) from the Superbar.
8-I got an Elevated Privileges alert everytime I do so, even though I check “Trust this application” and choose “Run Unlimited” (Take a look at the attached screenshot).
9-The alert shouldn’t appear and Opera Next should be allowed to execute itself, since I already chose to “Trust” her.

Extra info:

1-The shortcuts provided by Opera Software actually refer to launcher.exe which must load the latest build of an Opera stream (Stable, Next or Developer) when several of them are installed locally.
2-Killswitch process list attached

Anyway, even though it is the second bug I encounter in this Beta, it’s still quite nice to use, thanks Comodo team, and keep up the good work!

[attachment deleted by admin]

Thank you for reporting this. I edited the title in your first post. Please let me know if you think it suitably explains the issue you are experiencing.

Also, could you please attach the KillSwitch Process List to your first post. If you have any questions about how to do that please feel free to ask.


I’m not sure it’s completely suitable, since that for the time being, I didn’t experience the same issue with other software. But I guess it may happen with other software, so why not!

KillSwitch Process List added to the first post

Thank you :slight_smile:

Thank you for pointing this out. I have now edited the title accordingly.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I got something interesting for you!

I got the problem mentioned in the first post when everything in File Rating settings is unchecked, but when all of them in File Rating settings are checked, the Elevated Alert about Opera Next doesn’t appear anymore!

Hope it may be useful :slight_smile:

Sorry about the double-post, but I need to precise something, and since I can’t edit the last one…

In File Rating settings, ALL of the features must be enabled to make the Elevated Alert disappear

Thank you, and keep up the good work!

Thanks for adding this. It’s still a bug in my eyes, as it shouldn’t be necessary to add the files manually from the Rating Scan. Not all users will do that. Also, what do you mean when you say that “ALL of the features must be enabled to make the Elevated Alert disappear”? Do you mean that it’s not enough to just add the one executable to the Trusted Files List from the Rating Scan, but that other files must be added as well? Please clarify.


Thanks for your answer Chiron.

After I read your post, I uncheck the four features in File Rating settings, added both launcher.exe and opera.exe to trusted files, and the Elevated Alert appears again.

Then, I check the four features in File Rating settings again, and now, the Elevated Alert is appearing again! It seems it isn’t related to File Rating settings, after all…

Okay. I removed that information from the first post. This certainly is a strange bug. Hopefully the devs will be able to replicate it. If not they should contact you for additional information.


I have received feedback from the devs about this issue. Apparently, this is by design. In order for this to work correctly the file size must be lower then 40MB or maximum AV Realtime file size. Thus, you should be able to get around this issue by increasing the size of the maximum AV RealTime file size.

I will therefore move this to Resolved. If you find that increasing the file size does not solve this issue please respond to this topic and send me a PM with a link to this topic. I can then move it back to the bug reporting board for processing.

Thank you.

Thanks for sharing the devs’ feedback, I appreciate it.

opera.exe is higher in size than 40 MB indeed, so I guess increasing the file size could resolve the trouble.

I see Comodo 7 has gone RC today, good work, Comodo team! I don’t think I’ll test it yet, but I’m looking forward to the final version!

Do you know if the other bugs I saw were corrected in this release?

Thank you :slight_smile:

I’m not sure about other bugs. I passed on the information they provided. However, I’ve also seen cases where something was fixed but the devs did not alert me to it.