Changing Action frm Ask To Allow Fails for Crtng Custom HIPS Ruleset [V7B][M813]

  1. Issue:When I try to modify the default Action i.e. Ask in HIPS custom ruleset to Allow, nothing happens it remains on Ask

  2. Diagnostics report : attached

  3. COMODO Internet Security 7.0.308911.4080

  4. Windows 8.1 32 bit fully updated; VirtualBox 4.3.6

  5. Configuration changes : unscheduled virus Scan; Auto-sandbox set on Untrusted; FW settings : checked Blobk fragmented IP traffic, Do protocol analysis and Enable anti -ARP spoofing; Configuration set on proactive Security; Stealth Ports set on Block Incoming Connections.

  6. Clean install of CIS 7 on clean install of Windows 8.1; no configuration imported;

  7. No other or previous security software; no sandboxing software; only utility installed=Sysinternals Autoruns

  8. I try to make a HIPS Custom Ruleset for MpCmdRun.exe.

  9. In the Access Rights, when I try to change the Action from Ask to Allow by clicking on Ask then on Allow in the small window with “Ask, Block, Allow”, nothing happens, the small window closes and the Action remains on Ask.
    If I click on Block instead of Allow, the change takes place and the Action is set on Block.
    I’ve find a way to make the change from Ask to Allow occurs : in the small window, if I click on Ask or Block, then again on the Action which has been set (either Ask or Block) when I click on Allow in the new small window this time the change of Action to Allow is registered by CIS.
    I’ve tried with several executables namely Dragon and IE with the same result.

  10. Of course I expected to see the Action changed from Ask to Allow automatically when I click on Ask and then on Allow in the window “Ask, Block, Allow”

[attachment deleted by admin]

I can confirm this behavior on a real system running Windows 7 x64. I will therefore forward this to the devs.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have marked this as fixed for CIS version 7.0.312140.4101. I will therefore move this report to Resolved.

If you are still experiencing this problem please respond to this post and also send me a PM with a link to this bug report. If that is the case I can move this back to the bug reporting board and continue processing it.

Thank you.