Changes Made To CIS Are Undone After Restarting Computer [V7][M932]

A. THE BUG/ISSUE (Varies from issue to issue)

  • Summary - Give a clear summary in the topic subject, NOT here.
  • Can U reproduce the problem & if so how reliably?:
    Every time
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1: Change options in configuration (for example, disable the widget from being shown and register my LAN), selecting OK when finished
    2: Reboot the computer
    3: Note that the changes are undone and LAN is unknown
  • If not obvious, what U expected to happen:
    The changes should be saved and my Local IP should be remembered
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    I tried reinstalling CF by following the methods suggested here. However, that did not help. Also, uninstalling Mcafee did not solve this either.
    Also, I have seen this on all 5 of my computers.


  • Exact CIS version & configuration:
    CF 7.0.313494.4115
  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All enabled
  • Have U made any other changes to the default config? (egs here.):
    Only: 1) Disable splash screen 2) Disable widget 3) Register my LAN IP
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    [list type=lower-alpha][li]if so, have U tried a a clean reinstall - if not please do?:
    Yes, I did a clean install but it did not help.
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    Yes, but it did not help
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Win 7x64 and full administrator rights.
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=McAfee Antivirus b=None

[attachment deleted by admin]

That’s very strange. Please try reinstalling by strictly following the advice I give in this post. Although you have already tried reinstalling, please do it again by following these methods (including running the removal tools from Safe Mode.

Let me know if there is any difference.


I just finished doing your instructions.
Unfortunately no change.

I m doing changes and registrations, and after rebooting everything is back to the default

Are you remembering to select OK after making any of these changes? If not then I do believe it will not save the changes after a reboot. Please check this and let me know.


Yes always…
Also… I tried uninstall v7 and reinstall v6 in one of my machines and its working perfect with v6

Does anything change if you uninstall McAfee and restart? (You can reinstall Mcafee after checking).

Just did it… still nothing…

Strange thing is that v6 runs fine… I have problems only with v7.
If it was McAfee I should have problems with both v6 and v7.

Thanks for checking this. I edited your first post. Please look it over and make sure that everything is correct.

Also, please attach a diagnostics report and a KillSwitch Process list to your first post. If you are not sure of how to do that please feel free to ask.


Sorry but I have no idea how to get a diagnostics report and a KillSwitch Process list.
Can you pls give me instructions or links with instructions?

I have already completely uninstall comodo from 2 of my 5 machines because all those popups (welcome,new network, widget) were really annoying and I couldnt work…
I left the other 3 machines with the problem in order to troubleshoot it.

Now I am running my productive PCs on Win7 native firewall until we solve the problem.
Is Win7 Native firewall providing enough safety or not?

Create a diagnostics report by opening the main CIS GUI. Then left-click on the question mark icon and select Support and then Diagnostics. This will run the diagnostics and when it’s done, offer you the option to save the diagnostics report. Save it and attach it to your first post.

To create the KillSwitch Process List once again open the main CIS GUI. Then flip the window to the Tasks side. Then go to the Advanced Tasks section and left-click on Watch Activity. This will download and start KillSwitch. After it’s installed click on the menu for KillSwitch. Then select “Save Current View”. Once that is saved put that file in a zip file and attach it to your first post.

If you have any questions please do ask.


Files attached, although I am not sure if I want to continue troubleshooting anymore.

After 20 plus years of using McAfee (from DOS ages) I decided to give Comodo antivirus a chance.
So I downloaded and installed (In one of my machines) the Comodo Internet Security (instead of McAfee antivirus and Comodo firewall)
The machine so far runs ok and I am NOT facing the bug mentioned above.

If you want to continue the troubleshooting (just for the experience and knowledge) I will do it.
If you want to quit the hunting and declare the case closed is also OK with me.
In the 2nd case (although it is off-topic) just please give me a link with instructions on fine-tuning the comodo antivirus

Many thanks for your effort…

Honestly, this is a very strange issue to me. I have not heard of a problem like this, which is why I really thought that carefully reinstalling it would solve the problem. I was surprised when it didn’t. Then, my thought was that it could be another trusted program accidentally interfering in some way (which is why I thought about McAfee). However, even though McAfee is not the problem, it’s still possible that it’s another program. The Process List may help to narrow that down.

I’m going to forward this to the devs now for investigation. However, there was one other piece of information which may be helpful. You are saying that you see this on multiple computers. Is there any way you could create a KillSwitch Process List for each of the computers. This would allow the devs to compare them to see if there is a program in common which could be causing it. Also, once they have the Process Lists you would not have to do any more hunting. Anyway, if you would rather leave it as it is, that’s fine as well. Hopefully they can figure it out from here.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Dear Chiron
I am almost sure now it is a conflict between comodo7 and mcafee (comodo6 works fine)
Just for testing purposes I tried an old XP machine and I also have the same issue !!

So in order to give you more data on the issue, please find attached:

  • The requested files from another 7x64 machine
  • The requested files from another XPx86 machine

Hope I gave you a lot of info…

In any case, my decision is to abandon McAfee virusscan and adopt Comodo antivirus (which among others is free)

[attachment deleted by admin]

Thank you, but now I’m confused. A few posts above you mentioned that disabling McAfee did not change this situation. Did I misunderstand you at that time? If McAfee is removed do you still have these problems?


Sorry I might not was so clear…

With McAfee disabled and Comodo active I still have the problem (A rule? A service?)
With McAfee Uninstalled and Comodo active I still have the problem (Leftovers?)
With both uninstalled and reinstalled from scratch I have the problem… (A rule? A service?)
With both McAfee and Comodo uninstalled and Comodo reinstalled from scratch I have no problem…

This sounds like interference, which is a common issue. This may be evidence of an incompatibility, which can be forwarded for investigation anyway.

If there was interference when both are installed then, yes, it is possible that leftovers are causing issues. Please run the removal tool for McAfee I link to in my reinstallation topic.

Again, this sounds normal if the problem is incompatibility.

This would make sense if there was an incompatibility between the two as there would be no leftovers from McAfee left to interfere.

If my above analysis of the situation seems correct to you then I will update your first post, the title, and the tracker, to represent that this seems like an incompatibility with McAfee and its leftovers.


Yes, this is correct :slight_smile:

My final decision was to completely remove McAfee from all my machines and install Comodo Firewall AND Antivirus
I think it is running smoother…

In that case, as everything now runs smoothly, I will move this bug report to Resolved.

Thanks again.