Changed Lan Card No Firewall Protection

My Lan card wasn’t working well. I put another one. Firewall didn’t noticed this change. It’s not monitoring. I remember 2.4 used to detect when you change cards.


do you have “automatically detect new private networks” checked in the Misc —> Settings —> General tab?

Yes it’s checked.

Your LAN card doesn’t change your IP address. Go into the firewall section and click on my network zones. Do you see your new card there? Read “what do these settings do” in that section. It explains it all.

There was the old one there. I deleted the old one. No change

No in there it tells you how to add a new one. Click on “what do these settings do” which opens up the help file system.

I put my local ip address there. Still not working. I’m not versed in network stuff. This is getting too complicated. V2.4 would recognize when I change cards on the fly. Why this one can’t ?

Thats not how I did it. I typed in “home”. Then selected my new card from the drop down menu. Presto. What might be better for you is just to uninstall 3.0 completely and reinstall it. Then your new card will be there. Just follow the instructions in the help file. Be sure to read all the instructions.

I don’t see the card there. Not even a list

Did you follow all the instructions step by step? I did and it worked for me. If its too complicated then simply uninstall and reinstall. Only takes 5 minutes. I use Revo Uninstaller in advanced mode.

I tried to follow the instructions. It doesn’t work for me. I compare this release with Windows Vista. Windows XP worked fine for most users. Then in Vista changed were things are located making it a pain in the ■■■■ to find things. Not to mention resources but that’s not an issue with Comodo. Things that worked before require more “work” to work now. Same is Comodo v3. Things just worked before. You only needed to Open ports for p2p. Now it’s a pain to change a lan card because V3 doesn’t even notice I did. Right now I’m not even protected.

Its not that hard. Just uninstall Comodo 3.0 and reinstall it. Your problem will be fixed. 3.0 and 2.4 cannot be compared. 3.0 is more then a firewall. It is also a HIPS program.

I think Firewall with Hips or not should notice if I change my lan card. If it doesn’t, it’s a bug. Because 2.4 could notice . It must mean that 2.4 firewall is smarter than v3 firewall part.

This isn’t about wither or not Comodo 2.4 is better then 3.0 which it clearly is not. I am trying to help you so constant negativity isn’t going to help you. If you did everything the help file said about adding a new network zone then it should work. If not then simply uninstall Comodo and reinstall it. It only takes a matter of minutes then you will be back up and running. If you install a new mother board on your pc and Windows doesn’t recognize it nor does it have the drivers for it does that mean Windows is wrong. No. You just sometimes need to reinstall a product to make it work again properly. It is a common thing.

Did you follow all the steps and click on what I circled in the picture below?

[attachment deleted by admin]

Windows is an OS. OS in most cases have to be reinstalled when a motherboard is changed. But not if you just changed the lan card. So the situations aren’t the same.

I did that. Created a zone, I typed my local IP address. Still it was blind. I got the other card working again. And it detected it. It just didn’t wanted to see the realtek one wich is weird. It should see any card.

Before the firewall can recognise the new NIC, the OS has to acknowledge it. Was the card properly installed in Windows - i.e. did it show up as successfully installed in Device Manager? If it isn’t showing as OK there, it won’t be OK anywhere else.

Ewen :slight_smile:

True panic. When I install a new video card I cannot keep the old drivers. Even though Windows sees it I still need new drivers. When you installed your new card and at first boot up did Windows find your new device? It should have and you should have had to install the drivers if Windows didn’t have them already.

I had those drivers already. The card was working fine, no exclamation icons or question icons in the device manager. I was using it to post here. I think V3 has some kind of bug when you change cards or doesn’t recognize some of them. Anyways currently I’m testing Oupost to see how it goes. So far I think it’s great protection. And sites appear clean with no ads. One thing I noticed about Outpost is that it notices when I’m being portscanned by Shields up, etc. I didn’t get any notification in Comodo or anything in the log. But this is off topic. Topic may be locked or whatever. Still Comodo is a good free product. I will try Comodo again I’ll be keeping an eye on it. I was a user since 2.3.681. I think V3 still have some things to be ironed out. Like detecting cards. And I think it should display also what type of attack is blocking. Sometimes in the log I saw some connections were blocked in Opera and I don’t even know if they were attacks or anything or why they were blocked. Not very informative. Well that’s all I have to say for now.

*Note: I’m still using Comodo in my computer at work * :slight_smile: