CFW freezes if I run ransomware inside the virtual desktop [M1291]

1. The full product and its version:
COMODO FIREWALL 8.0.332922.4281 BETA
2. Your Operating System (32 or 64 bit) and ServicePack revision. and if using a virtual machine, which one:
virtual machine : virtualbox 4.3.6 r91406 , windows7 x64
3. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?:
COMODO - Internet Security
4. Did you install over a previous version without uninstalling first, or import a previous configuration file?:
Clean install
5. Other Security, Sandboxing or Utility Software Installed:
6. Step by step description to reproduce the issue. Or if you cannot reproduce it, what you actually did before it happened, step by step:
1: I ran the ransomware inside the virtual desktop
2: After running the sample, my computer freezes, both within the virtual desktop and outside the virtual desktop
3: During this time it’s not even possible to move from the Virtual Desktop to the real desktop
7. What actually happened when you carried out these steps:
I ran a sample inside the virtual desktop, but my computer freezes entirely within the virtual desktop and outside. Only a manual restart can fix this.
8. What you expected to see or happen when you carried out these steps, and why (if not obvious):
If the sample was run inside the virtual desktop it should not be able to freeze the real computer as well. The user should at least be able to shift back to the real system and find that unaffected.
9. Any other information:

[attachment deleted by admin]

Thank you for submitting this bug report. I made some changes to your first post. Please attach a diagnostics report to your first post. Also, please send me a PM with a download link for this ransomware, and a link to this bug report so I don’t confuse it with any other samples I may receive.


ok, thanks

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The issue has been resolved :-TU

I’m very happy to hear that. I have closed this in the tracker and will move this post to Resolved. If this re-appears in a future build please let me know by responding to this topic.

Thank you.