CFW Doesn't Detect Networks When Hyper-V Is Installed [M1493]

Comodo Firewall Doesn’t Detect Networks:
When Using Hyper-V External Virtual Switch Adapter
or Hyper-V is Installed But Never Run

Can you reproduce the problem & if so how reliably?:
Twice, both fresh, clean installs; on desktop & laptop

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Install Win10 Pro, enable Hyper-V feature
2: Configure external virtual switch in Hyper-V manager
3: Install Comodo Firewall (CFW)
1: Install Win10 Pro on laptop
2: Install CFW
3: CFW detects networks normally
4: Enable Hyper-V in Windows Programs and Features
5: CFW loses Network Zones (except loopback) and no longer detects/creates network zones

One or two sentences explaining what actually happened:
CFW detects networks on Win10 laptop just fine (pre Hyper-V); it does not do so on the desktop, which has Hyper-V bridge on the real network adaptor, and it does not ask or create network zones. Note that the physical network interface is not used by the host machine; the virtual interface is. Installing Hyper-V even without launching it causes issue.

One or two sentences explaining what you expected to happen:
…to be prompted Home/Work/Public network and respective network zone created

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Windows firewall was not disabled during CFW installation; I had to manually disable it

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
Searched for this issue; found the same issue reported on Win8 but was closed due to user not following up:;msg671797
Disabled Comodo’s driver on the physical interface; ensured Comodo driver was enabled on virtual interface (it was)
Disabled/Enabled virtual network interface to try to trigger detection

(edit) I had to manually create my home network IP in/out rules, following the laptop (working) rules in order to receive some traffic requests and perhaps filter outgoing requests.

Exact CIS version & configuration:
CFW, sans Chromodo, GeekBuddy

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Unchecked the reduce alerts option during installation; I never got prompted to identify network after restart

Have you made any other changes to the default config? (egs here.):
Yes but I can’t see what the defaults are. Firewall settings options are unchecked except:

  • Firewall: safe mode
    Traffic: on
    Alert timeout: 999
    Filter loopback

Have you updated (without uninstall) from CIS 5, 6 or 7?:
No, downloaded/installed a few days go, no program updates (only database)

Have you imported a config from a previous version of CIS:
No, N/A

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win10 10130 x64, fresh install from 10130 ISO
UAC OFF, Admin account, on host machine (not VM)

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
Malwarebytes Antimalware Premium was already install prior to installing CFW, which is the same configuration on the laptop (without Hyper-V) that doesn’t have this problem

Diagnostics zip is attached
I do not have KillSwitch installed

[attachment deleted by admin]

Updated. Even the mere presence of Hyper-V blows up CFW’s ability to detect networks.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Please check with Comodo Internet Security V10.0.0.6071 Beta thanks.

heh…sometime in the past 18 months, I’ve moved on to a different product. :wink:

Seems like another occurrence with;msg647356 so moving to resolved as it is already logged in the tracker as a deferred issue.